Simon-S14

S14 With Neo Rb25 Drift Car.

1,331 posts in this topic

Thanks really appreciate it :thanks: ill be driving up in the hilux tommorow as the 33 decided to kill its clutch pedal bracket on late notice...

ill be sure to say hi, still gotta get you to do that shift light too lol

Share this post


Link to post
Share on other sites

Good to meet you mate sorry I didn't get to take you for laps. Had issues then Decs from garage 7 rocked up and got stuck into data logging it. Found boost was spiking and cutting rpm.

Share this post


Link to post
Share on other sites

shakedown today at mallala... first time out and i had all sorts of cutting out issues... would just cut out big time in the midrange when on the throttle.. was hell weird. it wasnt until Decs from Garage 7 came along for a passenger ride and said its boost cutting. the target boost is set to 18 psi with a cut out at 22 psi to protect the engine from overboost (plus the map sensor only reads to 22psi so cant set higher) for some reason on the dyno it never spiked but on the track with some hard throttle mashing it spiked to 22psi and cut. so we backed the target boost back a few psi and problem solved.. now peaks at 18psi and doesnt overboost.

once that was sorted have it some hard laps and was pretty happy with the overall performance.. its a little bit lazier coming onto boost but once it is it just pulls hard. didnt bother going for lap times as i was running shit tyres and drift set up. was all over the shop with shitty half worn sunnys on the back lol.

Share this post


Link to post
Share on other sites

Good to meet you mate sorry I didn't get to take you for laps. Had issues then Decs from garage 7 rocked up and got stuck into data logging it. Found boost was spiking and cutting rpm.

that's cool Simon there's always next time, car sounds great with new setup!!! All the best for Tassie :thumbsup:

Share this post


Link to post
Share on other sites

Quick question with the dyno graph simon, with the rb25 head and stock cam you made same power on 98 and more torque than you are now with 26 head and running E85. I know your making less torque because of the manifold but I thought you should have see a max kw jump from the e85 and 26 head.

Share this post


Link to post
Share on other sites

nah what happened was when we first tuned it with BP98 and stock cams it was tuned on the dyno with no temp correction turned on. cause there was no temp probe so the dyno software automatically assumes 100 degrees ambient air temps. hence the inflated power and torque figures.

Share this post


Link to post
Share on other sites

thanks for the clarifications

Share this post


Link to post
Share on other sites

it means that the very first tune that we did on the first set up was out of wack yes... then the owner of the dyno (not my tuner, different person) purchased a temp sensor for the dyno so we were able to tune correctly from then on.

anyway.. bottom line is, yes its down on power but once cams and cam gears are installed it should bump it back up

Share this post


Link to post
Share on other sites

wow what an insane read from 1 to 41 tonight, awesome build man, im also in the process of building my 32, will hopefully be going too the same depth of mods as you on mine, might see you on the track!!

Share this post


Link to post
Share on other sites

Thanks mate. Day one of adgp is over and so far so good. Massive thanks to fellow sau'er appsy for helping out with tools etc to

Share this post


Link to post
Share on other sites

theres more.. and some hilarious ones to come... including me buried chassis deep into the rock pit that is the symmons plains kitty litter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now