nizmo_freek

Members
  • Content Count

    744
  • Joined

  • Last visited

  • Feedback

    0%

Community Reputation

3 Neutral

About nizmo_freek

  • Rank
    1997 series 3 r33 GTR
  • Birthday 07/08/1988

Contact Methods

  • MSN
    jasonpothoven@hotmail.com
  • Website URL
    http://
  • ICQ
    0

Profile Information

  • Gender
    Male
  • Location
    New Zealand, Levin
  • Interests
    cars

Previous Fields

  • Car(s)
    1997 Series 3 R33 GTR
  • Real Name
    Jason

Recent Profile Visitors

4,390 profile views
  1. nizmo_freek

    Would not having the NAV DVD in the navigation unit possibley be causing my problems?
  2. nizmo_freek

    Actually it does seem to be worse on a hotter/sunnier day, seems to not fault on cooler/darker days
  3. nizmo_freek

    The screen has been working all day today, hasnt popped back down after 3 secs like it has been doing the past few days. It now stays up but displays these messages and will sometimes goes black/blank. This is what the screen has been showing, anyone know what they mean? last pic looks like a symbol for a cd?
  4. nizmo_freek

    Hey guys Just got myself a 2005 350gt sedan, car is amazing but am having a few intermittent issues with the NAV screen at the moment This only happens sometimes but the problem is this, when the nav screen pops up it will pop up with a black screen then go back down after about 3 secs, it only does this sometimes. The car dealer i purchased the car from has agreed to pay to get this fixed but i dont think there will be anyone around my area thats had experience with these, he did say the nav screen was working when he had the car, but before he had the car delivered to me he had an fm band expander fitted and the ETC toll card reader removed (this was an aftermarket ETC, not the standard optional one), he seems to think there may be a lose wire/connection somewhere there from when this was done, the car also had a flat battery when it arrived from what i was told (not sure if this would affect it at all) Has anyone had the same problem before? if so what was the solution? The screen seems to be working fine today lol, any help would be great. Cheers
  5. Hi Rear tyres have gone bald on my gtr, is it ok to use a different brand tyre on the rear compared to what im using on the front aslong as they are all the same size? i will be using toyos on the front and possibly dunlops on the rear, will this be ok or will it cause problems with the 4wd? just want to be sure i dont cause any damage Cheers
  6. nizmo_freek

    Very nice, looks tidy, rare colour too! Good luck with the sale
  7. nizmo_freek

    Need some help asap. Just about to install the rear camber bushes now, but it looks like the end of the rear upper arm already has factory camber adjustment (never knew gtr's had adjustable camber on the rear from factory)??? The bolt that goes through the rear of the arm with the bush already has a big offset washer with degree markings on it, when you turn this bolt it moves the top of the hub, hence giving you the ability to adjust positive or negative camber. Do i mount the new bush in the hub now then??
  8. nizmo_freek

    Lol "nre" in that pic is meant "new" ,sorry, am in a rush lol
  9. Hi I just orderd myself a whiteline plus adjustable camber kit for the rear of my r33 gtr, just want to make sure im going to be mounting the bush in the right place. Am i meant to mount the new adjustable bush in the rear upper camber arm (the rear upper camber arm has a fork mount on one end were it bolts to the hub and a rubber bush on the other end were it bolts to the subframe mount), do i remove this and replace the factory bush with the whiteline adjustable bush? Or do i remove the hub and replace the factory bush with the whiteline bush were the rear camber arm bolts to the bush on the hub? Am 99% sure i put the new bush in the camber arm but just want to make 100% i am putting the bush in the correct place before i install them. Hope this makes sense lol Cheers Jason
  10. Hi I just purchased myself some 2nd hand nismo s-tune's for my r33 gtr, i cant figure out how to adjust the dampening correctly. As far as i know the front shocks have 5points of damper adjustment and the rears have 3points, problem is i cant figure out where exactly these points are. When i turn the dampening adjuster on all of the shocks i get infinate clicks clockwise and anti-clockwise, the clicks do seem to feel different sometimes, after the 4th click the distance between click 4 and 5 gets bigger. So for example i get can turn the adjuster for 4 clicks which all seem the same distance apart rotation wise then on the 5th click it seems i have to turn it more of a distance to get it to click. Does anyone have instructions for adjusting these or could possibly help me, anything would be great, hope my description makes sense Thanks Jason
  11. nizmo_freek

    Are they the australian spring rates for the BCNR33 type flex, resprung/revalved by fulcrum?? Jap spec flex (the ones that we get in N.Z) are 8kg front and 7kg rear!
  12. nizmo_freek

    What so great about the cusco's??
  13. nizmo_freek

    What are peoples thoughts on tein monoflex? Have been priced up on tein flex but might aswell spend a little extra and get the monos?
  14. nizmo_freek

    Am seriously thinking of those too, are rather exspensive though, about $2800 nzd just for the shocks, do you have any pics of your car with these fitted? want to see what the ride height is like