Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Techo

Stagea D I Y's, How To's, & F Y I's

Recommended Posts

Hey guys, Pom here.

Is there any info about draining and refilling the coolant system?

I seem to have some very nasty rusty looking water in my Stag and would like some info before i drop it all out.

Just how to refill and bleed the system would be great.

This site is brilliant for Stag info.

Cheers

Sy.

Share this post


Link to post
Share on other sites
Hey guys, Pom here.

Is there any info about draining and refilling the coolant system?

I seem to have some very nasty rusty looking water in my Stag and would like some info before i drop it all out.

Just how to refill and bleed the system would be great.

This site is brilliant for Stag info.

Cheers

Sy.

Here is a picture of the bleed valve - mine has a little tag on it that says "never open when hot(courtesy of SK):

Cam_Belt_Air_Bleed_Small.jpg

Share this post


Link to post
Share on other sites

Thank you :)

Is it just a case of taking the bottom hose off and draining it ?

I have seen the little cross headed screw thingy on the rad but after reading how they break then i'd rather take the hose off. I seem to have a little leak underneath the inlet manifold that's dripping onto the oil filter, Is there anything around there that's common for leaking ?

Also what kind of coolant to use ?

I got no service history or booklets with this car ( Big gamble huh !) So im literally flying blind at the mo.

Didn't stop me doing the high boost mod and chucking the Apexi filter on today though .. :P

Share this post


Link to post
Share on other sites

hey all i am new here have a rs4 97 had nothing but dramas since i bought it (not to the cars fault) had some drunk hit me in the rear 2400 for standard bar so the joy begain body kit (from monkey warehouse) all the prep that go's with it and then the fiting was bodgie after hours of work had to go with the best i could do was not happy and the the frount mount done with no effort at all and then the elec boost controller then was happy with the over all performance of the wgn even with the 4-5 coil pack miss unitl now was not that badthis is a family car if the idiot had not hit me it would still be stock execpt cat back. i have 9 month old twins and cant stand commodore's hance the stagea. the miss seems to be the coil packs i only run 7psi in it as i cant go any higher has any one fixed this prob with just new coil packs or do i just go and get fuel cut as well would like to run 10psi or higher (for when i am on my own) i am prepared so spendthe money for coil packs but that is it as it needs new suspension and need to save mu pennys

i would also like to thank everyone for this godly place would still be licking wounds if it was not for all the info found hear when ever i am in doubt i come STRAIGHT hear and find much comfort..

again many THANKZ to you all

will give my system a flush now

Share this post


Link to post
Share on other sites

Coil packs are expensive. have you checkd your plugs? Get a set of coppers gapped to 0.8mm (NGK BCPR7ES-8 are pre-gapped). If that doesn't fix it try to borrow some coils before you fork out for new ones (Yellow jackets seem to be as good as the splitfires but cheaper).

As for the tuning get an Apexi SAFC (old cheap one will do) and if you can find one an SITC for the timing.

BTW if you do a search on coil packs you'll find lots of ideas for insulating them with tape or epoxy.

Share this post


Link to post
Share on other sites

yer done the epoxy thing but they mere leaking spark everywhere i have a mate that can get spitfire's cheap (for me) how regular do you think i should gap my plgs??

What is SAFC and do they cost, and easy to install??

Share this post


Link to post
Share on other sites

Well annually should be fine for plugs but sounds as though you may need coil.

SAFC is fo adjusting air/fuel ratios .. will overcome rich/retard (what you were referring to as fuel/boost cut.

Basic models are $100 -$200 there is a flash one with blue screen in the skyline parts for sale of this website

Google Apexi SAFC for more info

Share this post


Link to post
Share on other sites

thanks heapswill ask my mate if he can get me one aswell as the coil's.....

are you born and breed in nz??

i am from kaitaia(though born in aussie so got the best of both worlds a convict and kiwi)

wife is from d'urville island.

the coil packs seem to bee the most common thing that stops boost is this right??

is this just because they are crap[ or is there a tech reason they cant handle boost??

will spend the rest of the night catchin up on SAFC

many thanx again

Share this post


Link to post
Share on other sites

I remember someone put some DIY intercooler cleaning but can't find it anywhere, think they had half and half mix of turpentine and metho from memory with a rinse of water at the end. I read on some other site people using vacuums to dry them out.

Share this post


Link to post
Share on other sites
I remember someone put some DIY intercooler cleaning but can't find it anywhere, think they had half and half mix of turpentine and metho from memory with a rinse of water at the end. I read on some other site people using vacuums to dry them out.
Yes its in the DIY sticky>intercoolers>>R34GTT i/c into stagea (and its kerosene and meths).

Share this post


Link to post
Share on other sites

(Yellow jackets seem to be as good as the splitfires but cheaper).

Don't buy the rip off splitfires (yellow jackets/Just Jap/Red jackets etc) as they're a poor substitute. The voltage output is all over the show and the latency is very slow. They also don't seem to last to long either.

Origional or Splitfires.

Cheers

Justin

Share this post


Link to post
Share on other sites

Magnecor seem good, had them on most my cars, looking at getting some made for the m35 aswell.

Share this post


Link to post
Share on other sites

Any tutorials on the r34 front end conversion?

There are a couple of build threads - try the search function and if that doesn't work Google often will.

Share this post


Link to post
Share on other sites

Can someone tel me why these links no longer work? is it just me o.O Im mostly interested in teh Automatic troubleshooting page as I am having issues with my attessa system at speed.. :wacko:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...