Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Please Help! Heater Core Leaking Again


begone
 Share

Recommended Posts

Hi all,

Just wondering if anyone has had this problem as well. I have replaced my heatercore about a month ago and now its leaking again. It took me 6 hours to do the whole job and I damn sure dont want to do it again... but i got a feeling I might have to!!! Can somebody please help me out before i have to pull the dash out again!!!!

Thank you

Link to comment
Share on other sites

Was it a new item or second hand?

What did the hoses look like, were they cracked or swollen?

Were the hose clamps in good nick?

I could ask more questions but you will have to at least find the source of the leak.

Link to comment
Share on other sites

hoses are on the outside of the car... uses plastic pipes direct from the core to go through the firewall.. so wont be hoses or clamps..

i guess unless its leaking outside and running into the holes..

Link to comment
Share on other sites

  • 3 weeks later...

ok this is a really bad problem i am having 2 brand new hater cores both died on me. Is there a mechanic on here who i can contact to help me out with this problem it would be easer for me to explain over the phone. Please leave me a message and i will contact you

Link to comment
Share on other sites

I had the same problem with my heater core. It was leaking the day before Christmas and i was driving to Port Macquarie from Sydney on Boxing day.

Rather than spend all of Christmas taking out my dash i just re-routed so i have no heater now. I think im going to change that because it is getting freezing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...