Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Got Soem Questions About The Apexi Power Fc


jrb92se
 Share

Recommended Posts

hey guys let me start by introducing myself my name is justin, i drive a 1992 silvia with an s2 rb25det motor swap, fmic,3 inch nurspec exh,greddy profec ebc,apex i powerfc, 290 rwhp 267 ftlbs torque @5700 rpm 12.5 psi. i have a question concerning my apex powerfc, i did some searching and found the faq you guys have and some other topics covering th pfc but none relating to my problem. basically the factory boost sensor on the pfc is illuminated in sensor check and seems for some reason to be getting voltage even though i dont have the apex boost control kit and run a greddy profec boost controller, the highest reading it will get is .4. i would fix it myself if i could read japanese (seems impossible to find commander instructions in english), im sure i just have to adjust it some way but if maybe one of you guys who has more experience with the pfc could help me out that would be great. thank you so much for your help!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...