Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Car Alarm Playing Up.


Raul
 Share

Recommended Posts

Hey there fellas,

I have a cheetah 'powercop' series alarm on my r32 gtst. I had it installed exactly 3 weeks ago to thsi day so it is fairly new. As i approach my car on the way to work, i disarm the car as usual, no problems. Then jump in and turn the ignition to 'on' and let the fuel lines prime up a bit, no problems there either. Then as i try to start the car over the alarm seems to be kciking in and cant even ehar the engine kicking over!.

In the manual it says to check the battery if it is dead or if the terminals are loose. The terminals are fine and all the service lights turn on and interior lights are on when the key is on the on position.

Also i have tried pressing the reset buton and turning the batteyr back up off but to no avail!

Please any suggestions?

Link to comment
Share on other sites

Hey there fellas,

I have a cheetah 'powercop' series alarm on my r32 gtst. I had it installed exactly 3 weeks ago to thsi day so it is fairly new. As i approach my car on the way to work, i disarm the car as usual, no problems. Then jump in and turn the ignition to 'on' and let the fuel lines prime up a bit, no problems there either. Then as i try to start the car over the alarm seems to be kciking in and cant even ehar the engine kicking over!.

In the manual it says to check the battery if it is dead or if the terminals are loose. The terminals are fine and all the service lights turn on and interior lights are on when the key is on the on position.

Also i have tried pressing the reset buton and turning the batteyr back up off but to no avail!

Please any suggestions?

There still may not be enough cranking amps in the battery put some jumper leads on from another car and try again to start it, if the siren was chirping while trying to start then it tells me that you may have low battery power in the car and the starter motor is trying to get power from anywhere in the car such as the back up battery siren.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...