Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Who Broke Their Turbo?


Recommended Posts

Hi,

How many people out the have broken the exhaust wheel on their stock r33 turbo from turning the boost up? Of course I have read this and that like most of us, but I want replies from people who have actually wrecked their turbo from too much boost. I have run mine at 14 psi for a couple of months now and it seems fine. And today just for a look I pulled a couple of degrees of the ign map, disconnected the wastegate hose and let it do its thing. I saw 20 psi under 4500 and of course it dropped off after that to about 16psi. How long have I got do ya reckon before she blows? Btw its back down to 13.5 psi now.

Nathan :pirate:

Link to comment
Share on other sites

Thread closed. Believe it or not, but since SAU started more than 7 years ago, this topic has been discussed before.

Please use the search function in future. It may be found here:

http://www.skylinesaustralia.com/forums/index.php?app=core&module=search&search_in=forums

While we understand that it can be frustrating to have your thread closed - Please consider that other members may feel it to be disrespectful and selfish of you to post a simple question, without using the search feature to review the wealth of information provided by said members over the years.

If you still feel that this action is unjust, then please PM me and we can discuss it further.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share



  • Latest Posts

    • TCU is enroute, should be here on Monday. Have just paid for a transmission locally, they've got to pull it out of the car and should be with me on Friday. Just getting little bits and pieces I need for wiring. Thinking about using a small bulkhead connector to run the transmission wiring through the tunnel as the trans plug is quite big.  So all going well i should have the box dummy fitted up next weekend and start wiring.
    • sure, just PM me your email....
    • Haha likewise, take my shit box for a spin and maybe you'll end up wanting a R33 shit box again lol...  
    • @Jasoncauser looks like a tight technical track, and definitely fun! Let's hope I make it to that day 😎  
    • The springs just lets the valve bleed off pressure/oil and it bypasses the feed gallery and heads back to where the pickup feed is On the LS the oil gets the the bearings...eventually  This vid explains the OEM pump well IRT the pressure release valve and how the bypass works The oil pressure light coming on intamitantly could just be a sticky valve, but, why pull something apart and not put something better in  I believe the low oil pressure light comes on somewhere between 5-10 psi Well will stick a gauge in after the installation to see what difference it makes at hot idle and higher RPM, and by high RPM I mean 6300 RPM.....LOL
×
×
  • Create New...