Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Front Mount Not Working


Recommended Posts

I'm a bit perplexed - my Blitz Lm front mount intercooler was working fine. But last time I drove it it didn't seem to be working. My oil cooler was also having problems and I'm wondering if the two are connected in some way.

Normally I get my full power and and my oil never goes above 80-85' but this time it was hovering around 90'.

Any thoughts???? What do you think the problem is????

Link to comment
Share on other sites

I thought I should add a photo, it might help:

skylineatwaggaonreturntripfrommtgambier20110508c.jpg

It was on my return from Mt Gambier to my home town, a little bit over 900km in the day.

Note that it only happened late evening/at night and all in about a 100km strip from jerilderie to lockhart.

Note that I've already cleaned the lights and windscreen off, it was much worse.

Thank god for the car bra.

(And mods you can move it if you think its OT).

Link to comment
Share on other sites

Lucky the same stuff got on your face otherwise we might be able to identify you. :thumbsup:

Those that know me have seen enough of me, those that don't aren't missing much!!

killer mullet..

30 years in the making, I had it at school [and being biker scum helps], I know its not 'fashion' these days, but I couldn't come at poo pants and hair gel.

Im a total noob. WTF is it? Some sort of clay?

The only thing i have ever had build up like that in any of my cars was a swarm of bees. lol. They lost.

yeah, midges from standing water, lagoons, swamps etc along the side of the road as well as Urana Lake - which is half full for the first time in probably 20-30 years. Had clouds of them, my headlights were so dim I had to drive at 60=70 km/h until I could get somewhere to clean it.

And Paul, if you order your car bra and then give it to me I'll 'customise' it for you no real problem atm

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



  • Latest Posts

    • TCU is enroute, should be here on Monday. Have just paid for a transmission locally, they've got to pull it out of the car and should be with me on Friday. Just getting little bits and pieces I need for wiring. Thinking about using a small bulkhead connector to run the transmission wiring through the tunnel as the trans plug is quite big.  So all going well i should have the box dummy fitted up next weekend and start wiring.
    • sure, just PM me your email....
    • Haha likewise, take my shit box for a spin and maybe you'll end up wanting a R33 shit box again lol...  
    • @Jasoncauser looks like a tight technical track, and definitely fun! Let's hope I make it to that day 😎  
    • The springs just lets the valve bleed off pressure/oil and it bypasses the feed gallery and heads back to where the pickup feed is On the LS the oil gets the the bearings...eventually  This vid explains the OEM pump well IRT the pressure release valve and how the bypass works The oil pressure light coming on intamitantly could just be a sticky valve, but, why pull something apart and not put something better in  I believe the low oil pressure light comes on somewhere between 5-10 psi Well will stick a gauge in after the installation to see what difference it makes at hot idle and higher RPM, and by high RPM I mean 6300 RPM.....LOL
×
×
  • Create New...