Jump to content
SAU Community

Fs: Brand New Velo Gp90Xl & Brand New 595 Federals


Recommended Posts

Hey there,

For sale is a BRAND NEW Velo GP90XL

I planned on putting it in my car for track days, but I just can't see it happening anytime soon so would rather clear space.

Paid $700, sat in it maybe 5 times and test bolted it all up, feels amazing by far the most comfortable bucket seat.

Also, don't be afraid with it being an XL - The standard is too bloody small and even my other smaller mates agree the XL is a better size.

- Comes with all mounting bolts too.

After $650 ONO

Also have two BRAND NEW Federal 595's in 215 45 17.

Incorrect purchase, my loss is your gain.

Paid $300, sell for $240 OBO

Will work out postage AUS-WIDE and pick up is fine in Adelaide.

Cheers.

post-93044-0-43446600-1338102826_thumb.jpg

post-93044-0-11945900-1338102877_thumb.jpg

post-93044-0-64470600-1338102962_thumb.jpg

post-93044-0-28553000-1338102975_thumb.jpg

post-93044-0-81904200-1338102983_thumb.jpg

post-93044-0-57130900-1338105908_thumb.jpg

post-93044-0-43852100-1338105919_thumb.jpg

Edited by GRANDMA
Link to comment
Share on other sites

  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



  • Similar Content

  • Latest Posts

    • medium amateur ?? VCT rather have than not and they NEO heads anyway... agree shouldnt be down there in revs agree but one  does stuff up at times and does help 😁
    • Sorry this is late, but I just changed mine on the GTT. They are 6.5T  I tried T5 at the start, they don't fit nicely and is all loosely goosey. T6.5 from eBay and it works fine
    • >complete amateur >1:24 at Winton laggy massive HP RWD R32 I dunno about the first part I would argue this use case probably doesn't need VCT, won't be in the rev range that it would ever be active!
    • Last weekend I changed out the noisy bearing in the rear. It went fine except the axle was super stuck in the hub. I eventually got it all swapped out over two days. The car is so much quieter but the ABS light came on. I freaked out thinking I'd put the bearing in backwards or used one without the integrated magnet for the speed sensor (lower E90's use a ring attached to the axle rather than built into the bearing). I checked the 2nd bearing I got, seems I got it right (black side in first). I bought a new Bosch speed sensor from eBay which arrived today, 10 mins to fit and cleared codes. No more ABS light.  My gut says I probably damaged it when pressing the bearings in and out as it kinda hangs in a bad spot - i should have removed it. Anyway, whatever, its quiet and fixed. I think the front bearings are ready for changing now, I can hear very slight noise that would have been masked by the dead rear one. Front ones are bolt in thankfully. Also bought the Nolathane rear subframe bushes and a Whiteline 16mm rear sway bar (OE is 13mm). I had this bar on my 330i but cbf'd removing it so just got another. The subframe needs to be lowered to fit the bar so i'll do bushes and bar at the same time. I was really temped to get solid aluminium bushes but they are really expensive and the whole subframe has to come out, not just be dropped which is not something I'm keen to do. 
    • who'd have thought and  some compression 🤔
×
×
  • Create New...