Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Got a Pulsar

Sau A.c.t. - What Did You Do To Your Car Today?


Recommended Posts

Cleaned up the engine bay a little. Painted some stuff black that looked out of place.

The more recent pics I've seen, It Looks Awesomer!!!

And yeah, bit of paintage changes lots. (I did some of this recently too.)

Today I drove it to work and back (as is the norm) expecting to still hear strange noises from my fuel pump in the heat of the arvo...

None came. Could it be that yesterdays tweakage fixed it? Oh baby I sure hope so !!!

If so, I'll be like :bunny: and then :banana: with a :D

Edited by Not a Pulsar
Link to post
Share on other sites

Today it's stick the OEM wind deflectors on the GTR.

Painted them gloss black and now fitting them without the little metal clips.

Just over getting rain dripping in when the windows slightly down.

I hate driving with all the windows up! cos I'm a smoker......

Shut da fK up

Link to post
Share on other sites

Today it's stick the OEM wind deflectors on the GTR.

Painted them gloss black and now fitting them without the little metal clips.

Just over getting rain dripping in when the windows slightly down.

I hate driving with all the windows up! cos I'm a smoker......

Shut da fK up

HOW DARE YOU SMOKE IN THAT CAR

Link to post
Share on other sites

Swapped ignitor with the unit Richard gave me for troubleshooting........misfire still present, however only doing it under DECENT boost now (whereas last drive it degraded to the point of doing it anything above vacuum, as well as on take-off). I suspect the original cause is now 'fixed' by swapping out my ignitor, however I think it f**ked my plugs lol. Damnit.

Link to post
Share on other sites

Normal bearing/seal etc gone in the old pump, nothing major.

Next SAU track day is probably the next outing.

thats good then

Installed poncams in my car today. It didnt take anywhere near as long as i expected. sounds mint and all ready for my tune tomorrow :)

which poncams?

interested to know the power figure?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now





×
×
  • Create New...