• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


David_j_p

Stagea Air Conditioner Not Cold

Recommended Posts

My Stagea Air con is not cold, even after a regass. anyone else have this problem?

My aircon is crap. I was wandering if it was a nissan thing or there is something wrong with it. I took it to an auto electrician who specialises in airconditioning. I told them it wasnt cold enough, and I didnt care how much it costs, I just want it cold! So they regassed it and put a dryer in it, and it made no difference. My 2001 Outback was twice as cold, im sure of it. I took it back to them and they said its as cold as they get. If i set the climate controll to 18 degrees even on a long trip on a mildly hot day, it doesnt freeze your face off. If I did this in my previous cars, it would get uncomfortably cold after 30 mins of driving. Im not convinced that its "normal" for the aircon to be so crap. Does anyone have cold aircon? Maybe I should take it somewhere else?

Share this post


Link to post
Share on other sites

ummmm is the temp changing at all? as in if you go hot and turn it down does it get cooler, mine(r33) stays hot all the time cause of motor that adjusts the flap to control the temp is stuffed, dont know if its the same in a stag or not, have you tried running the air con diagnostic?

Share this post


Link to post
Share on other sites

18 degrees being the minimum the display can go, isn't that just open vent from outside? Try 18.5 degrees...

If it is indeed working, you will find the newer gasses are crap and perhaps that is the best you can achieve with them. Why the old gas needed to be drained out in Japan is anyones guess.

Share this post


Link to post
Share on other sites

If you try 18.5 degrees & the air starts blowing hot, its likely the cabin air temp sensor under the steering column is either disconnected or faulty.

Also, the climate control works through the daylight sensor as well - possibly if its not in direct sunlight, it won't blow 'face freezing' cold for a sustained period?

Share this post


Link to post
Share on other sites

My air cond is pretty chilly - got it regassed after the new engine went in. Do you have an automotive aircond shop in your town (rather than a sparky who does it as a sideline)? All Nissans seem to have the same system and a competent shop should be able to get it working for you.

Share this post


Link to post
Share on other sites

Thanks for your suggestions guys. I have an Xanavi system, and I ran the diagnostics, before and after the regass. The before was because, if I set it to 18.5, it was fully hot. If I put it on 18, it was cold, so no climate control :-) I suspected the sensors or the actuators. They returned no codes at all and when I made adjustments and watched the flap, it was operating as it should. One notch on the dial made the flap move one increment, it match every move, dial for flap. Anyhow the second diagnostic I ran afterwards was the same. Anyhow I gave up on the heating, in winter I dont care for the heating, but my wife has to fiddle with the dial when she is a passenger to stay comfortable lol. As for the cooling, I figgured if it was set to 18, and the compressor was running, then the aircon should be as cold as it can get. I will take your advise KiwiRS4T as this worked last time I wasted money on an auto elec for my skyline. The air con mechanic sorted it out right away.

Share this post


Link to post
Share on other sites

I have a 25G that is sussy in the temp dept. After a front rebuild the aircon was regassed but after a month or so, no more cool.

Air con man checked and there is a gas leak inside the car, behind the glove box. He said it would need a new condenser and TX valve.

His test unit is like a geiger counter. The electronic beep gets faster/louder when the gas is detected.

He must be right caus his name is Dave and he drives a Volvo. LOL

Share this post


Link to post
Share on other sites

Mine was not cold immediately after a regass. Ill get the aircon mech to test thoroughly for leaks. A new TX valve might be the go too. Thanks Hugh.

Share this post


Link to post
Share on other sites

Is the a volume or measurement of gas that a S2 RS4V holds/takes ?

Only reason I ask is mine needs to be refilled.

Cheers Lee

Edited by Stealth400

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now