Jump to content
SAU Community

anyone know the website


Recommended Posts

Hey Wreckedhead? was that you at EC last night? white 32? plates J**T?

if so!! congrats on the run!!! looked friggin awesome!! one of the guys captured your run as well! hehe... i could see you were extremely happy when you drove back to the lineup and met up with your mate!!!

congrats again!

Link to comment
Share on other sites

we were all jumping for joy, doesnt bother me who was driving, the car ran a good pass, and untill i get it caged i cant go back, hopefully in a couple of weeks ill sort it out and head back for some more runs

Link to comment
Share on other sites

The quicker your car runs, the more "safety" objects the car needs. Hence the cage for sub 11's, parachute for 140+mph etc.

LOL!!!! no kiddin! : i know the purpose of a rollcage.. and a parachute for that matter! he was implying he wouldn't take his car down the straight till it had a rollcage, but i just was wondering why it was then ok for his mechanic to drive and not him!

Link to comment
Share on other sites

Heh sorry for the confused reply, I guess if you don't own the car you're not going to treat it with mechanical sympathy.

The majority of drag strips in Aus operate under ANDRA, and their rules stipulate the safety devices for cars running certain times. If they know your car does xyz time and it doesn't have the gear on it, they won't let you run.

Link to comment
Share on other sites

hey Moanie i didnt have a choice, after my mechanic run the 10 sec pass, my car was banned from the track till i get a roll cage, i wanted to race it but couldnt.

and Doughboy you completely right, when i sit in my car and im on the line waiting to launch, all im thinking about is "what happends if the clutch blows or the diff pops or gearbox breaks, then im ****ed so i treat it with a little sympathy" but my machanic has no such feelings and slams everygear like mother****er not loosing any boost in gears.

but ill get my chance in a couple of weeks to run my 10 if im a good enough driver, its just a shame i didnt get to run the car with the gas.

Link to comment
Share on other sites

hey Moanie i didnt have a choice, after my mechanic run the 10 sec pass, my car was banned from the track till i get a roll cage, i wanted to race it but couldnt.

and Doughboy you completely right, when i sit in my car and im on the line waiting to launch, all im thinking about is "what happends if the clutch blows or the diff pops or gearbox breaks, then im ****ed so i treat it with a little sympathy" but my machanic has no such feelings and slams everygear like mother****er not loosing any boost in gears.

but ill get my chance in a couple of weeks to run my 10 if im a good enough driver, its just a shame i didnt get to run the car with the gas.

ahh!!! i see!! so he was the first one to run the 10sec pass? it should have been you!!!!! :)

and why no nos the next time?? you getting rid of it?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



  • Similar Content

  • Latest Posts

    • Well, try the new studs first, in case the US sourced studs are actually the problem. But given that the head is off the engine, at least it won't be too hard for someone to install helicoils if it turns out the holes are stuffed. You don't want to just run a tap or chaser through there if by doing so you leave behind 3/10ths of f**k all thread and the studs just pull straight out when you torque up the manifold nuts.
    • Hey everyone, I’m having a bit of a crisis and would like some advice.  I am in the process of assembling a head I had gotten back after NAPREC did their work. I had the exhaust studs removed prior to sending it to the machine shop, but afterwards when I tried threading in new studs, they wouldn’t go in straight. They would thread in smoothly by hand with almost no effort, but it doesn’t go in straight (noticeably circular motion) and eventually stops about halfway in. I had a couple go in perfectly straight with no effort, but when I removed them to try it again, they no longer when in straight and had the same issue as the others. The studs I’m using are M8x1.25, which I read was the standard. I did some research and decided to buy a chaser kit and new studs IEE NZ just in case. Has anyone experienced this? How screwed am I? Do I just need to run a chaser or tap and try again? Prefer a chaser because I heard taps can destroy existing threads.    Note: I also have a new set of intake studs that went straight in just fine that I bought from IEE NZ. I bought the exhaust studs from the U.S.
    • Photos. What you describe sounds impossible, given how the arms are assembled to the upright.
    • Hello everyone.  Since the last stint of turbo upgrades, the intake plumbing from air filter to turbo was made up of sections of ally pipe and silicone bends. This was done as the stock suction pipe was so restrictive, it was noticable on the dyno. The configuration and layout of the m35 engine bay meant that the intake plumbing was too close to the exhaust manifold, even in contact with the heat sheild in one spot. Apart from that i had to use the first section of the stock suction pipe bolted onto the turbo. Although the setup was much better than the stock suction pipe, it still caused some restriction and excesive heat into the incoming air. Its like trying to suck a thickshake through a thin soft drink straw, possible, but you gotta work really hard. Then add the heat...for those that may not know, the hotter the air, the further the oxygen molecules are apart and the less explosive a given area of air is when mixed with fuel, hence, why intercoolers work (compressing air makes the molecules move faster which also generates heat). Water injection and nitrous oxide injection also use the same principle.  As the M35 Stagea intake and suction pipe options on the market are very very limited, i decided to fabricate my own from the turbo to the filter and include one silicone joiner to allow for engine twist.  If anyone is interested while I'm in the process, I could manufacture a couple more but you gotta let me know soon. I'll post some pictures soon.
    • Hi everyone, I was wondering if anyone else has run into a similar issue. I recently installed ikeya Formula -15mm upper camber arms and lowered the car a bit. Right after the upright knuckle arm started to hit the upper camber arm making the car bottom out in while driving over small bumps in corners or dips on the highway. (Not even pushing the car) I was running HKS hipermax IVgt coils with 8K springs up front. Thought if i changed out the springs for 10K it would solve the problem, it did not.. Arms are still hitting. I asked a guy on instagram who is running the same upper arms, 8K springs up front and even a bit lower than my car sits. Guy has no problem of the arms hitting. Anyone else that has run into this issue or might have an idea of what could be the issue? I been told they might be installed backwards but the arms are as good as symmetrical and they fitted perfectly the way they are installed now.   
×
×
  • Create New...