Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Best AWD/4WD torque split controller


Recommended Posts

Best AWD/4WD torque split controller

Hi all,

I did a quick search but did not find anything which really satisfied me

I am looking at options for a awd controller

From what I hear the ETS pro is the latest and greatest but still applies line pressure even in 2wd mode and can cause transfer failures, are failures common? Has this been raised with full race?

Ruzic is no longer available but was considered the best, it still used the factory analogue sensor though, would this still be considered better than the ETS pro?

 

cheers

Link to comment
Share on other sites

Exquisit. I've had both.
The ets pro definitely does apply pressure when in 2wd. It turns the hydraulic pump off and does not prime. I had mine (r33) on hoist and fronts didn't turn.
Runic was good for track but much more subtle difference. Ets pro can be turned up, very aggressive. And 2wd mode can be fun.

Link to comment
Share on other sites

Thanks richard

So even though it applies pressure in 2wd mode it does not turn the fronts at all, so the premature wear would be minimal at least in 2wd mode

It would be interesting to see how the car behaves on a hoist with the setting in awd mode, is it suppose to drive all 4 even though the g sensor does not detect it is moving?

Ets seems to be better as it is newer and uses its own g sensor but I am concerned about premature wear on a street car

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Had both Ruzic and the Full-Race controllers, both good, but the dial and new G-Sensor make the Full-Race the winner.

.....I got a little creative and moved the controls to the steering wheel.

IMG_3630.JPG

  • Like 1
Link to comment
Share on other sites

  • 4 years later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



  • Latest Posts

    • Hi Guys, my car issues seem to be going from bad to worse and I’m hoping someone can offer some advice. I’m a Brit and have asked for help on the Brit forums but they’re not as active as they once were.    To save my thumbs I’m just going to copy and paste my posts from the Brit forum. I hope this isn’t considered lazy or rude:- 1st post…… For a while now my dash warning lights on my R34 GTT have been coming on. All of the them. When it happens the car runs like a bag of s**t. I pull over. Turn the car off and back on and the problem goes away. It doesn’t happen again for ages and then all of a sudden the dash lights up and the car is struggling. This has become more and more frequent and it’s now pretty much undrivable. I need to sort this out but don’t know where to start looking. A quick search around the forums and I’m thinking maybe coil packs but I don’t want to just change parts for the hell of it. 2nd post…… Ok the latest in the saga……. I decided to replace the spark plugs and coil packs to eliminate them as the problem. I figured they were over 20 years old and could do with being replaced anyway. I’ve just been out to have a go at changing them but the car won’t start. It turns over fine but won’t fire. I had a replacement CAS here so have swapped that out but it still won’t fire. Pretty sure I’m getting fuel to the injectors as I can smell it! Any ideas? Should the coil pack harness have a constant 12v feed once the ignition is on? Can I test this just by putting a meter across the + and ground pins? Is there a relay or something that should give the harness power once the ignition is on? Any ideas/advice would be appreciated. I’m at my wits end. Don’t know where to start looking really???
    • Hi guys, im a Brit who’s been using this forum for a while. I’m after some help so thought I’d come on and introduce myself. my name is Paddy and I’m an old man (46)! I own an R34 GTT in cloud white. Had it a good few years and do enjoy driving it! Also enjoy the attention it gets.  for those of you who are interested I’ve posted a couple of pics. Not the best pics in the world and they seem to of come out worse than the originals but you get the picture   Will post my issues in the relevant forum. I hope you guys can offer some advice.    thanks. 
    • Started installing the meth kit last night, managed to get it mounted so I could still access the awd resevior. Battery is located on other side I figured this was a nice spot for it. Cheers mates.
    • I saw the E in the model number and stopped thinking. Might not be correct there.
    • As soon as I come on boost that rear housing area, along with all the stuff connected to it will get pretty toasty and I'm not the type to race for a whole 10s or so 😘
×
×
  • Create New...