• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

Amit    0
Power cuts randomly

Hey guys,

this is my second post in this forum. I have this issue on my car for while hasnt been fixed and took to places they are not familiar with hope some one can relate to it or kow whats going on.

while ago say 3-4 months ago i have replaced the fuel pump(walbro255 high flow) as stock fuel pump was broken, and car wasnt starting so had to call mobile mechanic to come have a  look, and he discovered fuel pump was the issue and replaced with walbro as i mentioned above.

ever since i have replaced the fuel pump i have got weird driving experience, like it randomly cuts power like when  taking sharp left turn or right, driving on rocky roads or bumpy roads, and when u rev hard say past 5-6000 rpm the idle will sound funny.

before when car get stall i can turn back on straight away and drive but 3 days ago as i was driving car stalled and tried to start like normal it wouldnt start, it was choking and car died again. Tried for 15 mins atleast failed to start. As i was waiting for tow truck for 1 hr i thought lets give a shot to start it back again. And surprisingly it started. I didnt drive for 5 mins just wanted to see if it would turn off, but didnt . Drove back home which was 6 kms away.

havent drove since bit stress dont know how to explain to people they look confused after explaining to them. 

Any idea whats happening with the car. 

 

Please help this brother.

 

 

regards

amit

 

Share this post


Link to post
Share on other sites
GH05T    1,555

search afm connection solder fix

Share this post


Link to post
Share on other sites
KiwiRS4T    481

^^^what he said. Next time it won't start jump out and pull the plug off the AFM and see if st starts then.

Share this post


Link to post
Share on other sites
hy_rpm    21

Fuel pump may not be mounted low enough causing it to cut around corners
Also check afm voltage with nissan consult

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this