Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


robbo_rb180

Robs Sil80-more skyline than S chassis

Recommended Posts

3 hours ago, ActionDan said:

In that last glory pic, is there a pool of oil under it lol

Also are you tiny or is the driver f**king massive?

Yep, big milkshake under it. 

Anthony is a big bloke, driver seat is hard up against the roll hoop. 

Link to post
Share on other sites

My guess is his foot went through the firewall and kicked a hole in the block trying to get the old girl to pull up lol

  • Haha 1
Link to post
Share on other sites

Well spent a bit of time this week going over the 180sx in preparation for hill climb tomorrow. Compression test came back 115-120 across all 4, the blow by had filled half the compressor housing and Intercooler with oil so pulled it apart gave it all a good clean.

Dropped the oil and there was no shiney bits so fresh 20-60 oil went in with a new filter. Still blew a little bit of smoke on quick test drive so see how it goes tomorrow and may give it a bit more boost. 

Hopefully holds together for a few runs. 

Link to post
Share on other sites
1 hour ago, ActionDan said:

Cold and dry? 

warm. 


Ended up 5th outright with a 1.01:89 at the hill climb but only did 3 runs as blow by got worse. Thats a new pb too so will be alot quicker with a healthy motor
It was blowing oil up the boost solenoid ref line and out the port.
Tried venting catch can to atmosphere which helped a little bit but still pushing oil to catch can. On the last run turned it up to 22psi but blew off intercooler pipe on gear shift after launch so called it a day.
Pulling engine this week as couldn't find another one locally.

Link to post
Share on other sites

The only way a vent will help is if you vent the sump and the head separately like I did on mine. 

You need to equalise the pressure top and bottom. 

 

  • Like 1
Link to post
Share on other sites
1 hour ago, ActionDan said:

The only way a vent will help is if you vent the sump and the head separately like I did on mine. 

You need to equalise the pressure top and bottom. 

 

Will be doing whole new catch can/breather setup when I get this motor freshened up. Atp 2l can and all dash 10 lines.

Priced up everything for forged bottom end through golebeys so once engine is out and everything measured up will place the order. 

IMG_20200927_181348.thumb.jpg.71b2bbf3ae40c52f506c4b29e9b3960b.jpg

Link to post
Share on other sites
34 minutes ago, ActionDan said:

Even with a fresh motor, Nissans need bulk breathing capability. 

Vent it top and bottom and happy days.

 

2x - 10 off the top, 1x - 10off the sump and the factory block fitting should be hopefully help. Never had issues with the s14 but the rocker cover is a better design. 

Link to post
Share on other sites

Progress back moving under its own power. 

IMG_20201007_174738.thumb.jpg.83b25b9d2e9893a5c0c125ff7fe7f499.jpg

Been spending a little bit of time sorting out the power steering setup since I didn't end up going electric. Went with an aeroflow tank as I stuffed up the original one trying to weld on dash fittings. 

Cut off the old bracket and made a template, copy to aluminium, cut/drilled and folded. 

IMG_20200928_194210.thumb.jpg.69f65f3fdbc3797944de04bbb1bff9af.jpg

IMG_20200930_153657.thumb.jpg.f66e93551ad59addad0f9f5077750ba9.jpg

Finished making lines and filled with fluid only to find I had hoses the wrong way on the rack. Switched them around, Bled it up and everything thing was all good. 

Also fixed cooling set up by moving one of the fans, got a new nismo thermostat just incase as the old one was around 11 years old. New coolant with demineralised water and now temps around 80c at idle. 

IMG_20201007_084614.thumb.jpg.e1ffd3ddb4ed7c594531e95a326f870d.jpg

Still sorting idle with ethrottle as when I stab the throttle it doesn't return to idle smoothly or stalls so will keep adjusting the proportion and stall gain to make it right. List of things needed to get back on the road is getting smaller. 

  • Like 2
Link to post
Share on other sites
11 minutes ago, robbo_rb180 said:

sorting idle with ethrottle as when I stab the throttle it doesn't return to idle smoothly or stalls so will

That won’t be helped by adjusting the throttle pid settings, it will be your base throttle table referenced before closed loop takes over. 

  • Like 1
Link to post
Share on other sites
7 minutes ago, Ben C34 said:

That won’t be helped by adjusting the throttle pid settings, it will be your base throttle table referenced before closed loop takes over. 

Thanks for the info will have a look at that before I do anything else. 

Link to post
Share on other sites

Just spent a bit of time this morning doing a few small things like fitting indicators, rear speaks, shortening intake pipe and cooling plates. 

IMG_20201009_112451.thumb.jpg.4f5c5a6eaf7678d6c0a152e5ee911a47.jpg

IMG_20201009_114057.thumb.jpg.b9ece166766690ee0add7ef8c6632a7c.jpg

IMG_20201009_114413.thumb.jpg.003b932f31e2f56cdb412189ddfd5f83.jpg

Engine bay all done just need to fit a washer bottle in the corner 

IMG_20201009_122206.thumb.jpg.59fd6f3388b42fe214373688c030cea6.jpg

Thanks to @Ben C34 advice went back and checked the ethrottle setup and set it up properly so idle is smooth at 800rpm and doesn't stall ?

Big ticket items left is driver side lca, cat back exhaust and Coilovers. 

 

  • Like 1
Link to post
Share on other sites
1 hour ago, iruvyouskyrine said:

how much were the brand new indicators

 

Cheaper than r33 xenon lights ?

 

Were around $500 ? 

Almost looks like it came from factory with all the "standard" Nissan parts. 

IMG_20201011_131909.thumb.jpg.abdf121abd323d20e8d3eff173a3505b.jpg

  • Like 4
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×
×
  • Create New...