• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Sign in to follow this  
Kustom20

R33 RB25DET engine won't start ECU fault found ECCS clicking

Recommended Posts

Kustom20    62

Hi Peeps,

just thought to post this up, even if it comes in handy one day for someone with the same fault. As we know SAU is a great community for anything Skyline related

I wont go into full detail, just a basic overview - I recently completed mods to my R33 and got the vehicle tuned. After a long 2 1/2 years in prep and paint and taking the vehicle off the road. I had to remove all mods for RWC - the last 2 days I removed exhaust side and Intake side basically everything to change back to stock.

After fitting everything up and double checking to ensure I had covered all bases, checked earth connections, sensor plugs. Was time to fit the stock ECU and turn the key.

On the initial first cranking it did not start within 5 or so seconds, tried again, nothing at all. Was safe to assume something isn't working. After I turned the key to the off position I noticed a relay located next to the ECU kept clicking. ECCS relay - I thought it may have had something to do with the AFM wiring so I double checked it, only because one mod is the upgraded AFM - then tested the AFM wiring with Multi meter seems to have correct readings. And when I unplugged the AFM the ECCS relay stopped clicking. 

Also because I had changed to a S1 inlet manifold - I thought to also swap out the TPS with my S2 item. I then turned the key to on but not start and the ECCS was still clicking when the key was turned off. At this stage, I ran a quick ECU fault code diagnostic check - results were code 55 - no faults recorded. I installed the Apexi PFC back into the vehicle and got Co-Pilot running to set the TPS to the correct setting. And also check the sensor readings - everything seemed to be correct, except the TPS which was on 9.

Last thing was to open the Stock ECU housing - seen as it was sitting for 7 years to inspect inside for potential corrosion. And there it was as clear as day. Capacitor corroded. Also ran a quick test with the multimeter and found the number 2 was showing zero reading and all others were in the 460 to 470 range. Even though number 1 shows a reading but also corrosion I would be replacing this as well.

After finding this - i uploaded a base map back into the Apexi and car fired up straight away. Its kind of constipated going from 360kw back to stock ;)

IMG_2228.thumb.JPG.dba0e11860f3e06962f854b999606e61.JPG

IMG_2229.thumb.JPG.c0a8f41ca77bcbf5add99ef977ecd3b6.JPG

IMG_2230.JPG.ab932e0e02ee43068a014af50de6ab97.JPG

IMG_2231.JPG.69511c0330b8e8fda43752dee62cc709.JPG

IMG_2232.JPG.f49bd82939a10e00f4dd21178cd9252a.JPG

If it helps just one person in the future then its all well worth the very small effort.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this