Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

Model: V36 2009

 

I had this light on since I bought the car, originally being told it was just the bonnet light... But soon realised it was more than that, but at least it should just be a reset job as the light comes on when removing the front bar even...

So I went to a Nissan dealership to get it reset (as the dealership I bought it from said they didn't have the equipment) to be told that they don't have the tools to do it.

I haven't thought much since, and it went through rego last year fine. But this year it is now sitting at the rego place and he won't pass it with the light on.

 

Any suggestions? I tried the Nissan dealership again and they said they ca't do imports. I told them that I thought that if they can scan the R35 GTR's they should be able to scan this. He said no they can't.

I am really stuck now as it runs out of rego tomorrow. Anyone have any suggestions?

I read about turning the ignition off and on in the right timing but I think that just send it to diagnostics mode yes, so will still need Nissan Consult hardware/software?

I live in SW Sydney (Camden to be precise)

Edited by Pete_Repeat

Share this post


Link to post
Share on other sites

Looks like there is hope for me still :) Although I'm not sure if this is guaranteed to work. Fingers crossed.

Also a youtube version, but its for the G37 and its for the SRS airbag 

 

image.thumb.png.0684fd56f3ea6bfa2ae65588b0579220.pngOK so there appears some hope with the 

Share this post


Link to post
Share on other sites

That ought to work for you, unless your ECU has been flashed with the UpRev Osiris. In which case, it either needs the OEM code flashed back to it or the UpRev guys need to get a data dump of your ECU, correct the bug which causes that light to come up and then provide you with the modified code accordingly.

Good luck.

Share this post


Link to post
Share on other sites

Looks like you might have found the solution, but mate .... NEVER buy a car with a warning light on - you seriously believed them when they told you it wasn't a big deal? Surely they had tried to fix it and failed. Warning lights are there for an extremely good reason. Lesson learnt for others. I would suggest you have an underlying problem that NEEDS to be fixed - even if you follow the steps to reset it, surely it will come back until you actually fix the issue.

 

You need to find an import friendly Nissan dealer - random Nissan dealers WILL NOT help you - you have bought a grey import and subverted the whole retail stealership tree - Nissan HATES you, and your car. They DO have the tools to diagnose and fix it, but say they don't as they want you to suffer. That said, there are guys who work at Nissan who are occasionally sympathetic to our cause and/or own a Skyline themselves (I know of one here in Adelaide). Or you need to find a decent auto electrician with decent CANBUS compatible hardware and software (V35s/V36s are tricky though).

But like I said - just clearing your code is unlikely to make it go away - you need to fix the underlying issue(s). Hopefullly it is not a big deal, but given you were sold the car in that condition I would suspect something major - think about it - if it was easy to fix/clear the dealership that sold you the car would have fixed it.

Share this post


Link to post
Share on other sites
5 minutes ago, The Max said:

That ought to work for you, unless your ECU has been flashed with the UpRev Osiris. In which case, it either needs the OEM code flashed back to it or the UpRev guys need to get a data dump of your ECU, correct the bug which causes that light to come up and then provide you with the modified code accordingly.

Good luck.

Oh. Good... Then turned bad. I'm hoping the Ecu hasn't been flashed then as that sounds like a headache. It's got no aftermarket mods so I'm assuming it's still the stock Ecu code.. Hopefully 

Edited by Pete_Repeat

Share this post


Link to post
Share on other sites
4 minutes ago, Nightcrawler said:

Looks like you might have found the solution, but mate .... NEVER buy a car with a warning light on - you seriously believed them when they told you it wasn't a big deal? Surely they had tried to fix it and failed. Warning lights are there for an extremely good reason. Lesson learnt for others. I would suggest you have an underlying problem that NEEDS to be fixed - even if you follow the steps to reset it, surely it will come back until you actually fix the issue.

 

You need to find an import friendly Nissan dealer - random Nissan dealers WILL NOT help you - you have bought a grey import and subverted the whole retail stealership tree - Nissan HATES you, and your car. They DO have the tools to diagnose and fix it, but say they don't as they want you to suffer. That said, there are guys who work at Nissan who are occasionally sympathetic to our cause and/or own a Skyline themselves (I know of one here in Adelaide). Or you need to find a decent auto electrician with decent CANBUS compatible hardware and software (V35s/V36s are tricky though).

But like I said - just clearing your code is unlikely to make it go away - you need to fix the underlying issue(s). Hopefullly it is not a big deal, but given you were sold the car in that condition I would suspect something major - think about it - if it was easy to fix/clear the dealership that sold you the car would have fixed it.

I hear you. Hope you're wrong, but fair point. 

Occasionally the passenger side window goes up and down when I open the driver's side (like it's meant to when the door opens). They told me that was just a matter of resetting the windows occasionally (the hold down and the hold up reset/calibration) but I'm thinking it's more than that and the system thinks the passenger door is open when I open the driver's door. 

Yep, gullible I know. Let's hope it's not an expensive mistake. The car was checked out by an independent assessor with compression checks done on the engine so I'm hopng the  rest of it isn't hiding issues. I've had it for almost 2 years so I think I've found all the problems.

Share this post


Link to post
Share on other sites
33 minutes ago, Nightcrawler said:

if it was easy to fix/clear the dealership that sold you the car would have fixed it.

Reason I guess I didn't think too much is that the place is a general import dealer, so assumed they didn't have the proper Nissan consult software.. 

Share this post


Link to post
Share on other sites
28 minutes ago, Pete_Repeat said:

Occasionally the passenger side window goes up and down when I open the driver's side (like it's meant to when the door opens). They told me that was just a matter of resetting the windows occasionally (the hold down and the hold up reset/calibration) but I'm thinking it's more than that and the system thinks the passenger door is open when I open the driver's door. 

Yep, gullible I know.

No doubt about it, they got you good. I have the same model as you and it has never, ever need the occasional reset for the windows. I've had mine for just over five years and have only performed the reset three times because of disconnecting the battery working on stuff.

I would be checking to see what the status is of the passenger door switch when you actuate the driver's door switch. If they're both grounding, that means someone's possibly mucked about with the wiring and got those two door switches working in parallel. I'd be taking a good look at the BCM and its loom for any evidence of tampering/modification.

Anyway, that's a side note. Work through this dash light problem first and then progress to the windows. Good luck!

Share this post


Link to post
Share on other sites
45 minutes ago, Nightcrawler said:

You need to find an import friendly Nissan dealer - random Nissan dealers WILL NOT help you - you have bought a grey import and subverted the whole retail stealership tree - Nissan HATES you, and your car. They DO have the tools to diagnose and fix it, but say they don't as they want you to suffer.

Amen to that. Precisely why I bought my own Consult knock-off scan tool and software. Besides which, I only really trust myself anyway. :P

Edited by The Max
Quoted too much

Share this post


Link to post
Share on other sites

Well that worked a treat. Lights gone now. Rego passed with 1 day to go phew. 

Have since turned ignition on and off multiple times and it's stayed off. So good for now.... 

Share this post


Link to post
Share on other sites

Thanks for your replies. I was in a little panic seeing I had a perfectly good car off the road as of  tomorrow if I didn't get it registered.

Share this post


Link to post
Share on other sites

Hopefully the other lesson learned here was don't leave critical shit like that to the last day.

Share this post


Link to post
Share on other sites
1 hour ago, The Max said:

Hopefully the other lesson learned here was don't leave critical shit like that to the last day.

Hadn't thought of that 😮. Might stop putting things off, starting tomorrow.

Share this post


Link to post
Share on other sites

According to the previous owner, the light came on when the importer replaced the xenon lights with halogen ones to pass compliance and then back to xenon after it passed, mines a 2007 model. I tried to follow the on off guide but the light blinked times and then stayed on and didn't turn off after 7 seconds like that guide said

Share this post


Link to post
Share on other sites
7 hours ago, mitchy93 said:

According to the previous owner, the light came on when the importer replaced the xenon lights with halogen ones to pass compliance and then back to xenon after it passed, mines a 2007 model. I tried to follow the on off guide but the light blinked times and then stayed on and didn't turn off after 7 seconds like that guide said

I would have a scan tool run on it to be sure that it's not a legitimate crash recording in the pop-up hood module. If clearing the DTC with the scan tool does not clear the LED and the ECU has not been flashed by an early version of UpRev's tuning code, then chances are the pop-up hood module has some crash data recorded in it.

Replacing headlights will not cause this. My 2009 had the exact same procedure done on it for compliance, with no ill effect and I reverted them back to the factory HIDs myself, again with no ill effect.

Read my post in this thread about the crash module reset process: 

 

 

Share this post


Link to post
Share on other sites
6 hours ago, The Max said:

Replacing headlights will not cause this. My 2009 had the exact same procedure done on it for compliance, with no ill effect and I reverted them back to the factory HIDs myself, again with no ill effect.

It might if they thumped it hard enough to set off a crash sensor, or damaged the wiring, etc.

Share this post


Link to post
Share on other sites
14 hours ago, mitchy93 said:

According to the previous owner, the light came on when the importer replaced the xenon lights with halogen ones to pass compliance and then back to xenon after it passed, mines a 2007 model. I tried to follow the on off guide but the light blinked times and then stayed on and didn't turn off after 7 seconds like that guide said

i had this light monthly because i was always taking the front bumper off and disconnecting the sensors (i ended up moving them inside the crash bar to save time)
It happens when you disconnect the sensor and then start the car.

If you've done the following (below) then pull your bumper off and make sure all 3 sensors are plugged in. If they're not the light wont ever go away.

 

The procedure to reset Pop-Up Hood manually is:

 

1) Press twice the Start Button (Do not start the Engine, only instrumentation!)

2) wait about 7 sec, the Pop-Up light goes off ---> Press Start Button immediatly (Switch Off)

3) Press twice the Start Button (Do not start the Engine, only instrumentation!)

4) wait about 7 sec, the Pop-Up light goes off, Flashes 3 times, when goes off press Start Button immediatly (Switch Off)

5) Repeat steps 1-2-3-4

6) Press twice the Start Button (Do not start the Engine, only instrumentation!)

7) The Pop-Up light blinks slowly

😎 Turn Off

Share this post


Link to post
Share on other sites
On 5/12/2020 at 8:32 AM, GTSBoy said:

It might if they thumped it hard enough to set off a crash sensor, or damaged the wiring, etc.

I would guess that thumping the crash sensor would only trigger the warning if the vehicle was in motion and of course, that would trigger the rams.

Damaged wiring is a possibility but it would take a very conscious effort to achieve that because the sensor wiring doesn't run right up to the HID ballast connector. There's enough wiring up to the ballast connector to allow for the required cut and shut to wire the 12V up to the halogen lamps.

If the dude who worked on it managed to butcher it so bad, bugger me.

The only time I ever encountered this warning lamp without a crash was when I loaded UpRev Osiris into my ECU, there was a slight difference in the JDM ECU code to falsely trigger this DTC. To their credit, they were quick to resolve that for me but I've unloaded it because my dyno guy uses ECUtek instead.

Share this post


Link to post
Share on other sites

Turns out Rego inspections they dont care about that light. Mine passed Rego inspection today with no issues

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...