Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


My E90 BMW 330i


PranK
 Share

Recommended Posts

14 hours ago, GeeDog said:

Just spoke to him, and he said that somewhere around $75 rings a bell. He bought it a few years ago. I paid an extra $20 or so to get the battery coding module a few months ago. He also bought the OBD adaptor from Carly.

Oh cool. I have a little bluetooth OBD2 thingo, I'll test it with Carly - thanks for the info.

56 minutes ago, niZmO_Man said:

I use "Torque Lite"

Yep, I have the full version of Torque. Even though my VW used a protocol that nothing could read (unless you spent hundreds of dollars).... 

Link to comment
Share on other sites

That seat belt looks like one of the ones in my Commodore. Of course, the Commodore's 1996 vintage... :P 

I do love BMWs though, my first "want" car as a kid was a 635CSi, preferably in JPS racing colours. Maybe one day when the Alzheimers really kicks in I'll get one.

  • Like 1
Link to comment
Share on other sites

6 minutes ago, Hertz Donut said:

That seat belt looks like one of the ones in my Commodore. Of course, the Commodore's 1996 vintage... :P 

I do love BMWs though, my first "want" car as a kid was a 635CSi, preferably in JPS racing colours. Maybe one day when the Alzheimers really kicks in I'll get one.

Oh man, I have such a thing for 635CSi's. Actually, any classic BMW's. 

Link to comment
Share on other sites

The other day we set the air recirc setting - default is that it goes back to fresh, but I wanted it to remember the last setting, set the nagging low fuel messages to the lowest km left setting, set the windscreen wipers to complete a sweep when the car is turned off (like every other car I've ever owned does), and disabled the headlight washers.

Previously we changed the light settings when locking & unlocking the car, set a digital speed display on the dash, removed the legal disclaimer on the NAV, coded a new battery, and several other things that I can't think of at the moment.

Carly can also reset service reminders, although this can be done without any outside assistance, using the buttons in the car.

  • Like 1
Link to comment
Share on other sites

1 minute ago, GeeDog said:

Mine's ok - it has a "split" glass, where half is normal, and the outer 1/3 or so is convex. As a motorbike rider I mostly do head-checks instead of using the passenger mirror anyway.

Thats funny. I was just telling my brother in law yesterday that I can't change lanes without head checks cause of riding a bike. 

I don't think mine is split. I think I have the wrong mirror in mine. 

Link to comment
Share on other sites

Mine has a black vertical line separating the inner 2/3 and the outer 1/3 (maybe it's 3/4 & 1/4). Everything on the car side of the line is flat, the other side of the line is partly convex to give a wide-angle view.

 

20171218_155503.thumb.jpg.da4aaa8217c9aebf53443bdcdf250d4a.jpg

Link to comment
Share on other sites

  • 5 weeks later...

It hasn't all been rosy though.

The handling is odd. I believe I'm just a victim of run flats but its taking some getting used to. On a nice flat road its just gorgeous, but when there are ridges and pot holes it can tramline and pull a bit. I have been reading about my options for replacing them with normal tyres and either making room in the boot for a spare or carrying a small compressor + tyre foam stuff incase the worst happens. Prob is the Potenza's on it have SO much life left.

Can anybody else corroborate my run flats experiences?

My chrome window trims are super scratched and scuffed, so I plasti-dipped them black. Looked so shit, was so happy to be able to remove it straight away.

Also, I've found evidence of a terrible repair. So terrible that I'm almost embarresed that I missed this when looking at the car initially (though not nearly bad enough for me to not buy the car.)

The passenger side has had some kind of repair. The doors and bonnet trim gaps are a little off and there is a shit respray job done on the top of the doors. There is a bit of overspray and some paint coming off. The door jams and pillars are all original, so its just panel or paint damage thats been repaired. I'm not sure its worth fixing, but I would like to stop it getting worse, so I might just lay some clear coat on it. What do you think?

The first two pics are damage I did when I bumped it with my polisher, it just ate through. You can see some of the over spray in the third pic, but theres more than that.

20180109_163734.jpg

 

20180109_163728.jpg

 

20180109_163723.jpg

 

20180109_163716.jpg

 

 

 

 

Link to comment
Share on other sites

Hi Prank, congrats on the purchase!

Like you, I’ve recently wandered into BMW ownership with an E90 320i.

Your right about the runflats, I’ve had the same experiences with them. Luckily the previous owner only just replaced them because I will not be buying them when the time comes around, I just can’t justify the price!
You can get runflat “repair” kits(previous owner got one)but it’s not advisable to do so haha

Link to comment
Share on other sites

Hi Prank, congrats on the purchase!

Like you, I’ve recently wandered into BMW ownership with an E90 320i.

Your right about the runflats, I’ve had the same experiences with them. Luckily the previous owner only just replaced them because I will not be buying them when the time comes around, I just can’t justify the price!
You can get runflat “repair” kits(previous owner got one)but it’s not advisable to do so haha


Oh I'm happy that you're hating then too (well not happy but relieved) because I was starting to worry about suspension components.

Are you loving the E90?
Link to comment
Share on other sites

  • PranK changed the title to My E90 BMW 330i

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share




  • Latest Posts

    • If the timing check shows timing bouncing all over the place despite commanding a fixed value in the ECU then the most likely explanation is either the CAS drive pin on the cam has worn, the CAS drive gear has worn, or both. I suspect a number of the more severe cases of timing scatter are actually due to this issue.
    • I might try out the Direct Clutch twin plate, they run a mixed setup. 1x plate is organic 1x plate is ceramic  Which in theory makes it driveable, from what I hear it seems to be quite nice to drive from a handful of people. I've yet to experience this myself.
    • I was running the direct clutch services 1000hp rated twin plate clutch, I thought it was really nice, good pedal feel, not too heavy, a little ‘bitey’ on initial grab, but nothing excessive, got used to it pretty quickly, it held just over 500kw for over a year, when the car was pulled apart had it checked, was told plate wear indicated it had done what they considered’ bed in stage. Lol it will be going back in the car when it all goes back together. 
    • Right, so wheeeere were we. We were commuting around without a swaybar at the front for awhile. Until I heard... a...noise. A bad noise, a loud.. ticking...in-time-with RPM noise. I also noticed my power steering leak just wasn't going away. Wisely, I went to consult with an actual mechanic this time for a second opinion/further guidance. Upon hearing the sound, he immediately diagnosed it as Lifters (which is what it sounded like) but given I heard it from the bellhousing I thought it could be something in the bellhousing. Turns out the lifters are in the block, and that all immediately made sense. Phew, no need to worry about clutch/gearbox things, I have to worry about lifter things instead which as just mentioned, are in the block. Also: 1)      “Did you know your belts are misaligned and are starting to get chewed through?” Uh no, no I didn’t know that. Turns out my new underdriven alternator pulley that was a direct bolt on, was not a direct bolt on, and needed to be machined down as below it is compared to the one on my stock alternator. 2)      “Your aircon dye is leaking out the bottom and generally everywhere” Turns out the seals on my new AC system were 20 years old, and an old gasket had blown, all very surprising to me. These were replaced and system holding pressure now and no longer leaking.. 3)      Power steering leak was traced to the solenoid that was no longer being used and half disassembled from nearly fouling on headers. An O-ring was sourced, only to find that the housing of the solenoid body itself had a crack, and when removed found that the other side of it was flat. So a plate was machined up to just blank off the solenoid anyway, as the O-rings were in the rack itself. So no new rack needed. Hooray!   4)      I then learned my Power Steering had been broken since the conversion. What I thought was “Heavy but clearly working power steering” all this time was actually completely and utterly f**ked. The car now drives with slightly lighter than-OEM Nissan steering which was massive, massive, massive MASSIVE improvement which I didn’t expect! Still, the lifters thing. Then I had an idea, as my dipstick was still not connected to the car since the gearbox in (I had to get the bracket back from the other people). It was one of those last gasp ideas you have when you desperately want the problem to be something else. I had always historically overfilled my oil, and wondered if I was getting oil leaks (turns out I do not actually have ANY oil leaks.. but didn’t know it at the time) because something was just overfilled and it seemed to track. So I turned on my Accusump, filled up, then closed the valve. Left the car on overnight, checked the oil. ¾ of the way to H. Perfect. The way I always checked the oil. Still, mysteriously low oil pressure. I’m talking like 0.5 bar on the OEM gauge (which works in a R34). I then realized my accusump and oil cooler (a 25 row big boi) and lines are above the sump. I also remembered how I always check the oil overnight, after the car has sat. So as soon as I was starting the car, that oil cooler and lines would get re-filled again with oil from the sump, not exactly leaving enough in the f**king car. I went back to pick up car from mechanic and dumped a few liters into it and mysterious sound is now gone… and my oil pressure is a much healthier 3.5 bar at idle and moves according to RPM. That was a relief, to say the least. Still haven’t given  it a lot of RPM, as need to do my 1000km to get that gearbox all run in.
×
×
  • Create New...