• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Sign in to follow this  
froggy88

V36 Dash Lights

Recommended Posts

froggy88    2

Hi Guys,

My 08 V36 Sedan has developed an annoying issue with the dash lights. Part of the dash had started to flicker, specifically the 7 - 8 rpm section of the tacho. I see a few people in the US have had this problem but all the threads I have read the person just had it replaced at the dealer. 

Has anyone had something similar and know how to fix it?

Cheers

Share this post


Link to post
Share on other sites
niZmO_Man    1,290

I think it'll be a case of pulling the cluster out and replacing the dead LEDs.

Share this post


Link to post
Share on other sites
sonicii    118

I have had a few LEDs go out on the cluster of my V35, fortunately it was the driver transistors on the back of the board that had bad solder joints, otherwise I would have needed to remove the speedo/tacho needles to get to the front where the LEDs are and knowing my luck I would have either broken them, or never get them back on properly so would have an inaccurate speedo.  Either way, not a job for the faint-hearted.

Fairly unlikely to be failed LEDs, more likely a bad connector/solder joint.

Share this post


Link to post
Share on other sites
The Max    135

Agreed. Typically, if it's flickering and it is a genuine component failure rather than just a dry joint, it's the semiconductors driving the LEDs rather than the LEDs themselves.

Share this post


Link to post
Share on other sites
froggy88    2
  • Topic Author
  • Thanks for the responses guys! Hopefully it's just a bad solder instead of the LEDs dying. I did notice that the left side of the speedo is flickering now as well,sorry not as bad as the tacho tho. 

    Any idea where I could get this looked at in Perth? This isn't something in willing do myself!

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    Sign in to follow this