• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

hey guys, got my boss kit off this morning and noticed the steering angle sensor isn't sitting straight. i didnt install the kit myself so i dont know what had been f**ked with before i acquired the car. should a spin it around til the logo is up the correct way?

its a series 1 gts25t 1993 with hicas and no air bag. need help before i take my car in the shop later (unrelated) otherwise ill have to put the wheel back on for the job then take it off again when i get home. 

also worth a mention, there is no horn wires anywhere. do i need an adapter or something? is the plug on the steering angle sensor the horn plug? if so where can i buy the adapter i need? nissan?autopro?ebay?

WIN_20180117_205909.JPG

Share this post


Link to post
Share on other sites

The drive pin on it only engages the boos in one orientation.  You can't f**k it up.

My advice is to remove it, stomp it to pieces, then fit the required HICAS eliminator kit.

Share this post


Link to post
Share on other sites
  • Topic Author
  • Solid advice but that doesn't really help. And since I like my hicas, you're suggesting spinning the steering angle sensor into the upright  position can't do any harm? 

    It has been driving fine, I wouldn't have noticed if I didn't take the wheel off and see its orientation. Maybe it makes no difference? Does it recalibrate itself when the battery is out? 

    I'm only asking cos every pic I see of the damned thing, it's upright and mines sideways 

    Share this post


    Link to post
    Share on other sites

    early models and late models have a different standard angle. 

    *edit, im thinking R32 so this may not be accurate, but possible :) *

    Edited by GH05T

    Share this post


    Link to post
    Share on other sites
    4 hours ago, Dontspankmabitchup said:

    Solid advice but that doesn't really help. And since I like my hicas, you're suggesting spinning the steering angle sensor into the upright  position can't do any harm? 

    It has been driving fine, I wouldn't have noticed if I didn't take the wheel off and see its orientation. Maybe it makes no difference? Does it recalibrate itself when the battery is out? 

    I'm only asking cos every pic I see of the damned thing, it's upright and mines sideways 

    Well, there's only one of a few things that can be happening here.

    1.  You have stock steering wheel.  There is only one orientation in which the drive pin from the sensor will engage in the stock boss.  Therefore it cannot be put together wrongly unless the wheel is seriously not straight with the wheels dead ahead.

    2. You have an aftermarket wheel with a HICAS compatible boss.  Assuming it's the right boss for the car (see GH05t's post above) then I suppose some cretin could have bolted the wheel onto the boss 1 or more bolts out of alignment.

    2a.  But if this was the case, then you simply could not drive it more than about 10km without the HICAS computer going into a panic anyway.  So if your HICAS is working properly, then there is nothing wrong.  If the sensor is wrong, then the HICAS that you claim to like is probably not working any time anyway (and someone probably either pulled the globe or pulled the plug from the HICAS computer).

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • the light comes on after about 10 minutes of highway driving. 9 times out of 10 it feels fine but it has felt like it favors turning one direction more than the other. there is an occasional battle where it tries to correct me when im flying round a bend but as i said before its kind of more so on one direction so half the time it feels fine.. and besides, its pretty subtle.

    its an after market wheel thats been fitted, so i kinda figured maybe the knobhead who put it in fiddled with the sensor, i dont think its happened while driving, im guessing he just put it wonky and accidentally change the sensors orientation.

     although... a little while ago i had a steering issue i never got to the bottom of. my indicator stalk was arcing out and smoking and while this was happening it felt like the car wanted to zig-zag, i pulled the stalk apart and gave it a clean, re greased it and put it back in, and it was fine, had to replace a lot of fuses after that happened, and after i replaced them all the steering felt like it was normal again... or normal ish, i couldnt tell if i was feeling  the occasional sway or if hicas was just doing its thing and i was paranoid after the last issue. so unless some how that changed the orientation of the sensor, but that doesnt seem like something that can happen, so my vote is on human interference.

    i was thinking of just buying a new one all together and being done with the "fix some other dream boats sloppy arsed work' bullshit, but i cant afford to buy shit i dont need so i want to be sure... and even if i did... i still cant find my horn wire. and someone is yet to tell me if that female plug on the sensor is the plug for my horn. if it is then i need to hunt for a male that fits. it would be easy if i was the one who removed the stock wheel cos it would all make sense but i feel im trying to build a cabinet with missing pieces and no instructions.... its a bloody ikea model skyline. everyone i ask says the horn plug is on a wire but i cant find anything like that on mine

    anyway... all that nonsense aside....

    what to do... so you guys are saying IF this boss kit is the right one for my hicas, it should only go on one way with the steering angle sensor... correct? because of this "drive pin"?

    and IF it was on correctly then the sensor shouldn't be sideways, yeah?

    so to fix my issue i should put it on and see if they move in unison, and if they dont, then i need a new boss kit? 

    and IF a new boss kit IS what i need, once i buy one it should be safe to assume that i can freely spin the face of the sensor upright as long as my wheels are straight, line it up with the boss, make sure the top of the boss is at 90 degrees, connect the dream boats, smash my wheel on and its good as new? is that all correct?

    Share this post


    Link to post
    Share on other sites
  • Topic Author
  • 8 minutes ago, Dontspankmabitchup said:

    "fix some other dream boats sloppy arsed work'

     

    8 minutes ago, Dontspankmabitchup said:

    it should be safe to assume that i can freely spin the face of the sensor upright as long as my wheels are straight, line it up with the boss, make sure the top of the boss is at 90 degrees, connect the dream boats, smash my wheel on and its good as new?

    i didnt realise the C word gets altered to dream boat.. sorry for my colourful language.. i type how i talk, please dont mistake it for strong feelings of any kind.

    Share this post


    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now