• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

Debating going to a Spool spline Drive oil pump gear setup, has anyone seen any failures, weird wear?

I currently have a Tomei Pump, Recently broke the Snout of my crank off at the track (no idea why) this has me thinking about switching to a different perhaps better setup.

 

Whats everyones thoughts on this these days..

Share this post


Link to post
Share on other sites

I purchased one last year and have put it into my new engine, but I haven't started it yet. Well made and the clearances were perfect, so in theory it should be a good thing.

Share this post


Link to post
Share on other sites

Yes, I've seen that thread.. more less just wanted to here some people that have a few years+ of use/abuse on them.

Share this post


Link to post
Share on other sites

There’s quite a few workshops in Melbourne who’ve used them with N1 oil pumps for years now. From Rb28’s to RB34’s. No failures or breakages, have run mid 7 second passes well over 1000hp and 8500rpm without issues and still going strong. Wish I did it when I had my motor built

Share this post


Link to post
Share on other sites
On 5/16/2018 at 4:49 PM, mitchum said:

Debating going to a Spool spline Drive oil pump gear setup, has anyone seen any failures, weird wear?

I currently have a Tomei Pump, Recently broke the Snout of my crank off at the track (no idea why) this has me thinking about switching to a different perhaps better setup.

 

Whats everyones thoughts on this these days..

If you have a Tomei Pump you do not need to scrap it. We supply a full conversion to Spline Drive. You would be better off with a Tomei as it it a better overal Pump.

D4CB4B58-AC83-4468-B4AE-D96D9D41E860.jpeg

Share this post


Link to post
Share on other sites

I'm confused, a tomei rb26 oil pump is a spline drive. What Harmonic damper were you using when the snout snapped?

Edited by burn4005

Share this post


Link to post
Share on other sites
16 hours ago, Frracer said:

If you have a Tomei Pump you do not need to scrap it. We supply a full conversion to Spline Drive. You would be better off with a Tomei as it it a better overal Pump.

D4CB4B58-AC83-4468-B4AE-D96D9D41E860.jpeg

I went with the Spool gears, yours are almost double the money.. i agree the Tomei pump is a better housing however.. having that much flow seems to cause more issues then it fixed..

 

Edited by mitchum

Share this post


Link to post
Share on other sites
3 hours ago, burn4005 said:

I'm confused, a tomei rb26 oil pump is a spline drive. What Harmonic damper were you using when the snout snapped?

Its still driven by the conventional method 2 flat spots on drive.. there are splines on the Tomei gears but not technically a spline drive.. my Tomei didnt fail me however it got pretty beat up with the crank snout breaking. I was using a Ross pulley.

I went back to an N1 pump housing i ported the entry and exits so it flows a little easier.. 

Tomei pump is good and all but having that much flow isnt really needed IMO.. causes more issues than it fixes with oil pooling in head and or sucking sump dry... Stock VG30 pumps and 2JZ pumps work just fine for 1000hp.. no reason a properly driven N1 pump cant supply a sufficient amount of oil.

  • Like 1

Share this post


Link to post
Share on other sites

I've also went with spool spline drive gears, but in a standard rb26 oil pump housing. 

You may need to pull out the locating dowels on the block. 

Share this post


Link to post
Share on other sites

Pretty few and far between on a 2J though.. not to mention those are probably powdered metal gears or whatever junk they use..

But thanks for posting.

Share this post


Link to post
Share on other sites

I have installed the Spool spline drive gears in a New N1 housing that i ported a bit. Its in the car and running. Seems to be working well.

 

My only concern was the fairly low pressure at idle.. used to be about 20psi with the Tomei. It is now at around 12psi hot.. but goes up quickly with revs so should be fine as long as it doesnt go any lower.

This engine should make north of 800whp so report back if anyone wants updates.

  • Like 1

Share this post


Link to post
Share on other sites
21 hours ago, mitchum said:

I have installed the Spool spline drive gears in a New N1 housing that i ported a bit. Its in the car and running. Seems to be working well.

This engine should make north of 800whp so report back if anyone wants updates.

Would be good if you have a few pics of the work on your pump housing?

And with the hp level, presuming you might have the right sensor setup to log oil pressure?  Be good if you can post up a log run to show oil pump performance

Share this post


Link to post
Share on other sites

Mines got the Spool gears in it too and is on the dyno at the moment, I'll get them to data log a power run on the Motec and post a graph. I've got about 22psi at idle with 80C oil.

  • Like 1

Share this post


Link to post
Share on other sites

FWIW (might not even be on-topic) but I also decided to NOT go the spline drive route, after reading countless forums, blog posts, watching fat Jim talk about oil pumps and shit it seems the general consensus is that the spline drive needs the motor to have perfect tolerances, etc.

Most of the time when we build motors, we all end up line boring the block, this "generally" shifts the crank position by a bee's dick and because your oil pumps cannot be shifted that direction by whatever you end up unevenly driving the spline drive.

With my new motor for the shitbox, I just re-used the OEM NEO oil pump (which I believe it similar as a N1) and used the Spool billet gears. Crank was machined down, and the extended collar fitted with 2x grub screws.

I also run a host of sensors and can log oil pressure vs. engine speed vs. oil temp and water temp for anyone interested. It's on a Haltech Elite with no additional boxes (no need to insert Haltech box jokes). Happy to post whatever data people want :)

 

  • Like 2

Share this post


Link to post
Share on other sites
1 hour ago, Dose Pipe Sutututu said:

 

Most of the time when we build motors, we all end up line boring the block, this "generally" shifts the crank position by a bee's dick and because your oil pumps cannot be shifted that direction by whatever you end up unevenly driving the spline drive.

 

This is exactly what happens when you line bore, and when you do go spline driven pumps you are meant to take out the locating pins on the block for the oil pump. Install the pump, finger tighten the bolts turn the crank a few times to center it up and then tighten the bolts to spec. 

Share this post


Link to post
Share on other sites
23 hours ago, Dale FZ1 said:

Would be good if you have a few pics of the work on your pump housing?

And with the hp level, presuming you might have the right sensor setup to log oil pressure?  Be good if you can post up a log run to show oil pump performance

I just blended the entry and exits inside the pump so they would flow better than a straight sharp edged hole.

3 hours ago, r34unit said:

This is exactly what happens when you line bore, and when you do go spline driven pumps you are meant to take out the locating pins on the block for the oil pump. Install the pump, finger tighten the bolts turn the crank a few times to center it up and then tighten the bolts to spec. 

I used a dial indicator to setup the pump, drilled the dowel holes larger in pump housing and centered pump over crank with 2 dial indicators. What ive noticed over the years of building these engines is even from the factory..  the alignment isnt spot on, which could be the reason some guys get away with stock oil pumps alot longer than others.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now