• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Sign in to follow this  
Reeky

Neo 33 turns but won’t fire

Recommended Posts

Ok here’s a list of exactly what I’ve done for my r33 neo. This is whilst retaining all r33 bolt ons, plenum, oem coilpacks with the loom, injectors & rail with the loom using a s2 R33 rb25 engine loom and starter motor loom.

comtinues to turn really strong, but no firing up. Fuel pump works fine

-changed plug for o2 sensor to suit neo
-changed vct solenoid plug to suit neo
-extended the TPS plugs to reach neo throttle body
-reversed cas
-variable air control intake solenoid valve plug changed to suit neo & canister purge control valve plug to suit neo

That’s about it. IGN relay is there, ecu is in, white thing is plugged in I’m pretty sure it’s in properly.

 

Share this post


Link to post
Share on other sites

Have you ever started it before? Fresh fuel?
Maybe check that the fuel filter feed is the right way around otherwise is does exactly as you described.

Share this post


Link to post
Share on other sites

Pull out cas and turn it, listen for injectors and also pull off no1 coil pack and see if it creates a spark. 

From memory the 2 middle wires on the cas need to be swapped for the plastic covered to be used with normal metal ones. 

Share this post


Link to post
Share on other sites
On 9/16/2018 at 5:27 PM, hey_aleks said:

Send a pic of your engine bay aswell.

All lines are correct, filter is correct feed way so is the reg, all on the correct flow ways

Share this post


Link to post
Share on other sites
On 9/17/2018 at 12:13 PM, iruvyouskyrine said:

1 and 4 (outer wires) need swapping on plastic CAS

I gave that a go and still no fire up, tried these combinations

4231, 4321, 1324 and still no go

Share this post


Link to post
Share on other sites
On 9/16/2018 at 10:44 PM, robbo_rb180 said:

Pull out cas and turn it, listen for injectors and also pull off no1 coil pack and see if it creates a spark. 

From memory the 2 middle wires on the cas need to be swapped for the plastic covered to be used with normal metal ones. 

So 1324?

Share this post


Link to post
Share on other sites


R34 CAS (Hitachi)
pin 1 = earth
pin 2 = power
pin 3 = 1 deg
pin 4 = 120 deg

R33 Cas (Mitsubishi)

pin 1 = 120
pin 2 = 1
pin 3 = power
pin 4 = earth
 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this