• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Sign in to follow this  
sledgehammer

Weird boost sound (audio file included)

Recommended Posts

Hi all,

recently bought a Nissan Skyline R34 GTT with the RB25DET. So far everything runs great, however I noticed that the sound of acceleration is a bit weird.
I'm not sure what it could be. Turbo leak maybe? I included a sound file in this post. Is the noise normal?

Also, during the winter I might want to do some checkups. Would you recommend to do a compression test, even if I don't notice any lack of power or blue/white smoke? 

Thank you!

 

IMG_5469.mp3

Share this post


Link to post
Share on other sites

Hi mate,

A few things to check...turbo manifold, casket and piping to blow off valve. Turbo itself may be on the way out. 

Cheers 

Share this post


Link to post
Share on other sites
4 hours ago, Robocop2310 said:

Hi mate,

A few things to check...turbo manifold, casket and piping to blow off valve. Turbo itself may be on the way out. 

Cheers 

Thank you! I‘m going to check it. Would be surprised if the turbo is blown as I‘m driving on standard boost. On the other hand it‘s already at 160.000km. 

 

5 minutes ago, tridentt150v said:

What type of BOV is it?

It‘s the stock one. Could it also cause the problem?

Share this post


Link to post
Share on other sites

Sounds like it could be blocked off, but its hard to tell from that clip.  If it was aftermarket it would more easily explain the sound, they are always louder for the rice racers.

Share this post


Link to post
Share on other sites
2 hours ago, tridentt150v said:

Sounds like it could be blocked off, but its hard to tell from that clip.  If it was aftermarket it would more easily explain the sound, they are always louder for the rice racers.

No aftermarket, but I will check it. I just hope it‘s not a turbo damage.

Just found this video and while driving it sounds pretty much the same:

 

Share this post


Link to post
Share on other sites

I'm better on blown ceramic blades on the turbo itself or something to do with the BOV. 

Check all hoses and also ensure clamp connecting the BOV is fastened tight as they are known to come loose sometimes. 

Share this post


Link to post
Share on other sites

Won't be blown turbo.  They don't get "damaged".  they get f**ked.  And then they don't have any blades at all and they don't drive at all and there is no whistling noises.

It'll be a boost/exhaust leak, same as always.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this