• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Sign in to follow this  
TheKenso

Rb25det s2 isues at 4500rpm

Recommended Posts

I know ther is a million posts about this but every singel post i read havent helped me yet.

I have the "standard" isue about the car strugeling/cuting at 4500rpm, after a wile it wil boost/fule cut if i keep holding the throtle, if i let go a bit i migth get it past 4500, but usaly dont. Turbo gets glowing hot, but car is running rich, dont have a afr but car spits flames.

Mods:

- 3" exhaust

- Pod filter

I have tried: 

- Changing plugs and gaping them

- new coils (yellow jacket)

- tried 2 difrent AFM's and mesured them

- cheked fule presure,, 36psi with vacume, 41psi wirout

- tryed to take out cat

- tryed to discobekt boost selinoid

- timing is 15° at 650-700rpm

Share this post


Link to post
Share on other sites

Yellow jacket coils are prone to failure, OEM or blue Splitfire are best...…..set your gap to 0.8.  But without a programmable ECU or SAFC etc it will go R+R.

Share this post


Link to post
Share on other sites
On 1/8/2019 at 4:18 AM, tridentt150v said:

Yellow jacket coils are prone to failure, OEM or blue Splitfire are best...…..set your gap to 0.8.  But without a programmable ECU or SAFC etc it will go R+R.

What is wrong with the Yellow jacket? If they are so bad why are they stil sold? Shoud work fine on a stock car as far as i know

Share this post


Link to post
Share on other sites

They are unreliable cheap arse copy factory #876 Chinese crap.  4 out of every 6 are usually f**ked in the box.

Share this post


Link to post
Share on other sites
4 hours ago, TheKenso said:

What is wrong with the Yellow jacket? If they are so bad why are they stil sold? Shoud work fine on a stock car as far as i know

They are sold to unsuspecting people.

Seen any high powered RBs with them? Nope.

I ran then before, brand new set. 2 died, then a 3rd. Had 2x coils replaced then gave up. Money better spent on strippers and cocaine. Mind you it was breaking up at 1 bar boost, pathetic. Bought brand new Splitfires and put 1.7bar through it no worries.

A poor man pays twice.

Also try stock boost.

Share this post


Link to post
Share on other sites

I run Yellowjackets, no issues (1.1mm spark plug gap). Although my engine is standard everything.

Once you start leaning on them, you'll run into problems. There's a reason they're cheap, and a replacement for standard engine/turbo/boost level (it gets you going at the very least).

If you're planning on more power, do what the others above said.

Share this post


Link to post
Share on other sites

I used to run yellow jackets on my stock engine and after less than 5000kms one of them died. Never again.

Share this post


Link to post
Share on other sites
11 hours ago, Dose Pipe Sutututu said:

They are sold to unsuspecting people.

Seen any high powered RBs with them? Nope.

I ran then before, brand new set. 2 died, then a 3rd. Had 2x coils replaced then gave up. Money better spent on strippers and cocaine. Mind you it was breaking up at 1 bar boost, pathetic. Bought brand new Splitfires and put 1.7bar through it no worries.

A poor man pays twice.

Also try stock boost.

you guys need to read what im writing, car is STOCK exept for Exhaust, filter and coils, rest is completly stock, stock boost, stock fule, stock pistons, i baugth yellow jacket becasue it seamed like an OK change from originals on a STOCK car that is not gonne be tuned

Share this post


Link to post
Share on other sites

Yeah and there's a chance those coils are causing the issue too.

Go borrow a set of stock coils or Splitfires and if the problem goes away you owe me a beer lol

Share this post


Link to post
Share on other sites
2 hours ago, TheKenso said:

you guys need to read what im writing

You need to read what I wrote.

Share this post


Link to post
Share on other sites
4 minutes ago, GTSBoy said:

You need to read what I wrote.

so Austrailai is china? Nice

Share this post


Link to post
Share on other sites
55 minutes ago, TheKenso said:

so Austrailai is china? Nice

Not sure what that was suppose to mean, but judging from your responses you're not a very receptive person.

Share this post


Link to post
Share on other sites

Also if you have a thing against Asians, maybe go through your belongings and throw everything out that's made in China, Taiwan, Vietnam, Thailand, Philippines, Japan into the bin - that includes your car too.

Looked at your profile, I think you meant Nissans not Nissan's. Plural vs. Possessive.

Share this post


Link to post
Share on other sites
20 hours ago, Leroy Peterson said:

I used to run yellow jackets on my stock engine and after less than 5000kms one of them died. Never again.

I'm surprised mine are still going even after track days. But they'll probably start failing after I post this.

In saying that, I drove my car once last year so it's not like it's used a lot.

Share this post


Link to post
Share on other sites
12 hours ago, TheKenso said:

so Austrailai is china? Nice

What sort of dumb shit statement is that?

I wrote, "4 out of every 6 are usually f**ked in the box."

Share this post


Link to post
Share on other sites
19 hours ago, Dose Pipe Sutututu said:

Not sure what that was suppose to mean, but judging from your responses you're not a very receptive person.

i have tons of respeckt, but when he tels me a Australien firma is chinese somthing dosent make sens to me

 

Share this post


Link to post
Share on other sites
7 hours ago, GTSBoy said:

What sort of dumb shit statement is that?

I wrote, "4 out of every 6 are usually f**ked in the box."

 

On 1/16/2019 at 10:36 PM, GTSBoy said:

They are unreliable cheap arse copy factory #876 Chinese crap.  4 out of every 6 are usually f**ked in the box.

 

Share this post


Link to post
Share on other sites

The shop that sells them may be in Australia but they're made in some Chinese sweat shop for about $1.50.

In summary, they're shit.

Share this post


Link to post
Share on other sites

Yuh, it's hard to believe that anyone could think that anything so cheap and nasty could be built anywhere other than ChinaBay.

Share this post


Link to post
Share on other sites
1 hour ago, TheKenso said:

i have tons of respeckt, but when he tels me a Australien firma is chinese somthing dosent make sens to me

 

Wut?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this