• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


hey_aleks

R33 knocking/tapping noise from lower timing belt cover

Recommended Posts

Hey guys, so I'm in the middle of moving (can't start taking things apart too much because the car needs to be able to be driven to the new house).

I have a consistent light knocking sound coming from the lower timing cover. I thought it was rod knock since the knocking is consistent at idle and increases with rpms.

I used a broomstick to determine that the noise was coming from the lower timing belt cover BUT when i pushed on the cover a bit too hard, the noise sort of died down/changed (the noise changes depending on how hard you push on the cover). What do you guys think it could be? This all happened after I boosted the car to 120km/h when it was relativity cold (stupid). I'll work on the car when I'm finished moving but it's killing me not knowing if the engine is f**ked or not. Any help is appreciated.

Share this post


Link to post
Share on other sites

Could be anything tbh.  Water pump, HB, belt, CAS, oil pump, idler wheel, cam wheels etc all live under there.  Could even be something loose inside the covers? You will have to strip the covers off when you can. Just too hard to diagnose otherwise...they would only be guesses.

  • Like 2

Share this post


Link to post
Share on other sites
23 hours ago, tridentt150v said:

Could be anything tbh.  Water pump, HB, belt, CAS, oil pump, idler wheel, cam wheels etc all live under there.  Could even be something loose inside the covers? You will have to strip the covers off when you can. Just too hard to diagnose otherwise...they would only be guesses.

Yeah thanks for the advice mate. I've taken off the top cover so it's nothing under that one, so it's something to do with the bottom cover (which I don't think I can take off without removing the timing belt, need to move houses first). Hopefully nothing internal. 

Share this post


Link to post
Share on other sites

The cover will come off with the belt on.
Its the pulley and drive belts that are in the way.
You may need a puller or to make one.
Use the bolt holes on the pulley dont use a clasping puller.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Latest Trader Topics