Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


thebe

Ecr33 speedo reading half after Gearbox change

Recommended Posts

Hello.

 

I I have r33 gtst that was converted from auto to manual with rb20 box (RB71C). With this gearbox the speedo was spot on, reading mph. I think the odometer is also reading miles incase it helps anything. The car spent a year or two in the uk before I got it.

 

After first tune with my rb30 build the small box started making bad noises so got myself s2 (atleast sold as s2) rb25det gearbox. After the swap from rb20 to rb25 box, my speedo is reading exactly half the real speed. Like if I'm driving 60 mph real speed (GPS), my speedo is only showing 30. Regardless of speed its always reading half.

 

The rb25 box wiring loom was cut when I got IT and none of the wires matched colours to my cars loom (6 wires in both looms). After little playing around I got my neutral and reverse lights on cluster to work correctly so I guess the speedo wires should be correct too? Tried switching the 2 wires on gearbox the other way around, but no help.

 

Does anyone have any ideas on whats going on or what I could do to fix this? It's quite annoying as my steering feels very light now, specially at higher speeds. I've read that with manual conversion you also need a manual cluster, but with the rb20 box it was working spot on so that sound a bit strange to me. Despite living in Finland (we use kph) I like the mph reading as it can read higher than 180 kph. A simple dial face change would save me the trouble of calculating, but thats not my biggest issue right now.

 

Any help greatly appreciated! Thanks

 

Share this post


Link to post
Share on other sites

RB20 box is a cable drive (in an R32).  RB25DET box is electronic sender.  These two drives are completely different.  For example, to use an RB25DET box in an R32, you have to make a speedo drive that fits into the RB25DET box and provides a cable drive.  You can't use the R32 RB20DET speedo cable drive because a), it wont fit into the big gearbox and b) if it did fit the gearing on it would be wrong.  We typically build such a drive out of a Navara ute speedo drive (because they used the same big box but had cable drive speedo).

You have the opposite situation, in that you have a box that should not have been able to take an electronic sender (the RB20DER box) in an R33, which does not have a cable drive speedo on the dash. So the first question is....how was the RB20 box speedo drive achieved?  Is there an unexpected electronic sender in it (like, maybe from an S13?), and is there some sort of pulse frequency converter added into the wiring to get the frankensteined thing to read "correctly" on an mph speedo?  If there is a signal converter, it might be responsible for messing with your now notionally "correct for the car" gearbox and sender installation.

Edited by GTSBoy

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...