Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


SeanR32GtSt

New hypergear fitted over the weekend.

Recommended Posts

Fitted a new highflow rb25 hypergear turbo over the weekend with ease. With my mates lift and his help we got it done in bout five hours. Along with a new tomei 3” downpipe. My question is how many miles do y’all typically put on your new turbos before you start doing pulls in them. So far just baby driving to and from work I’ve got about 75 miles on it. I’ve scheduled a dyno tune next Friday for official HP numbers. 

Link to post
Share on other sites

^^^what he said...you need the tune before you can start thrashing it...or even driving it really. Have you got bigger injectors, fuel pump, and an aftermarket ecu or  nistune chip?

Link to post
Share on other sites
1 minute ago, KiwiRS4T said:

^^^what he said...you need the tune before you can start thrashing it...or even driving it really. Have you got bigger injectors, fuel pump, and an aftermarket ecu or  nistune chip?

I have a walbro 255 in it and a Nistune chip. I had it tuned back in October on the stock rb20 turbo and we found the stock fuel pump was very weak so few weeks ago I replaced it with the walbro and then this last Sunday threw the new turbo in. 

Link to post
Share on other sites
2 hours ago, Dose Pipe Sutututu said:

Baby it around, get it to barely come onto boost. 

Check for leaks, fill it up and drive to your tuner.

Send It!

Basically what I have been doing. Saw 2-3psi max. Seen a tad bit of coolant in the garage floor but not totally sure if it’s residual from the swap or a tiny leak at the banjo

Link to post
Share on other sites
1 hour ago, HCR32 type M said:

what else have you done ie exhuast, injectors etc etc?

 

It has full 3” exhaust from turbo back. Has a FMIC. Splitfire coilpacks. Walbro 255 fuel pump.a Nistune chip.  And a turbosmart manual boost controller. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...