Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Chrisko33

Hks fuel rail issue with sard 800cc injectors

Recommended Posts

Hi guys have been upgrading my r33 gtr I have purchased a Hks fuel rail but I am using 800cc sard injectors.Everything seemed to be lined up fine except the plug on the back of the injector when I tried to click it in seems as the fuel rail is to close has anyone encountered this issue? Do I need injector extenders? 

9AE07AF2-432A-46FE-98AC-223D149C6965.jpeg

0AD2C081-AF2E-4AF1-B579-548D71227957.jpeg

Share this post


Link to post
Share on other sites

Oh, my, god. Really ? What injectors were you running before as they are not the standard injector bosch type EV1 style connectors. You are trying put the connector on upside down for a start as the push release goes the other way, but it still won't fit - why ? I'll tell you.

The Denso / Sard 800cc low impedance injector uses the Denso "low" guide connector and your loom is fitted with the Denso "high" guide connectors (which are on the Denso / SARD low impedance 1000cc injector by the way).

You need the Denso low guide connector or butcher the injector side guides (cut off) for those 800cc ones.

Or just get rid of that and get some 980cc + Bosch EV14 injectors, then you can delete your resistor pack.

Share this post


Link to post
Share on other sites
3 minutes ago, BK said:

Oh, my, god. Really ? What injectors were you running before as they are not the standard injector bosch type EV1 style connectors. You are trying put the connector on upside down for a start, but it still won't fit - why ?

The Denso / Sard 800cc low impedance injector uses the Denso "low" guide connector and your loom is fitted with the Denso "high" guide connectors (which are on the Denso / SARD low impedance 1000cc injector by the way).

You need the Denso low guide connector or butcher the side guides (cut off) for those 800cc ones.

Or just get rid of that and get some Bosch EV14 injectors, then you can delete your resistor pack.

I ended up trimming the front clip part that  was hitting the fuel rail they fit on fine now 

Share this post


Link to post
Share on other sites

Don't need to trim anything with the right connectors as those connectors are either upside down when you were trying to fit, or they were put onto your wiring upside down mate. You are still using a high guide connector on a low guide injector, hence being upside down (wrong).

Share this post


Link to post
Share on other sites
1 minute ago, BK said:

Don't need to trim anything with the right connectors

They where the connectors that came with the injectors in the box I will look into the denso low guide connector if they are a better fit I’ll swap them 

Share this post


Link to post
Share on other sites

Really ? From New ? That is strange. Ok so you've cut the stock connectors off yourself and done this. You get what I'm saying right ? Why did you not go the much superior Bosch EV14 injector ? The Denso / Sard injectors are not cheap new for such an old design.

Right connector from EFI hardware in Vic.

https://www.efihardware.com/products/1512/injector-plug-Japanese-low-guide

Share this post


Link to post
Share on other sites
10 minutes ago, BK said:

Really ? From New ? That is strange. Ok so you've cut the stock connectors off yourself and done this. You get what I'm saying right ? Why did you not go the much superior Bosch EV14 injector ? The Denso /Sard injectors are not cheap new for such an old design.

Yeah I understand what your saying it was strange the injectors where brand new unused.  I ended up buying them for a really good price , I couldn’t say no to it was a good deal i was after hks1000cc ones and has one lined up new and the deal fell through, I am gonna run e85 now late change of plans on the build I’m hoping they can get me to 400akw or near that 

Share this post


Link to post
Share on other sites

The HKS / SARD / Power enterprise injectors are all SARD injectors and are not meant for E85 like the Bosch EV14 though. The 800cc will surely be too small for 400akw on E85 as they will struggle to do that on 98 unleaded.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...