Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


MoMnDadGTR

Canada 1993 gtr ready for action

Recommended Posts

Always good to get out and do a little tuning with my main mate. We got her up to 20psi on boostane. If your going to run the full 116 octane with this stuff make sure you adjust your fuel and ignition maps to accommodate. I don’t think it matters I much if your just adding a little bit but a full bottle of boostane to a tank and you definitely need a tune for it. Cheers gunna try 23 psi today, also picked up another rb26 swap project today so lots of good stuff coming up!

7EC00F97-671F-4878-8FAA-F5BE77885EA4.jpeg

DDD94137-417C-45D5-958D-308FDF1B8E31.jpeg

6DDE4A4F-A6B1-4A63-91E7-1D55B83D6C69.jpeg

  • Like 1
Link to post
Share on other sites

Lol. My buddy couldn’t afford to insure it so I figured why the fack not mates. It actually drives and runs awesome I just can’t stand the sound of the v8 she’s getting a 26.  Drift/bag in the Bush car probably gunna be more fun that the gtr. 

2DB7DBDE-5104-4B8A-A91A-89A4BD1E9DD5.jpeg

9F2798A1-EB0B-4521-9C20-E2D55519C32F.jpeg

04FE6875-8339-4024-BC98-D67461C92700.jpeg

E10E7EAD-FFA2-472B-A4F7-6C6A5DFF030F.jpeg

  • Like 1
Link to post
Share on other sites

Rb26 vs m60 v8. Lol I’d rather have oil issues than listen to that wanker v8. Although probably a better engine than the rb lol. Almost a shame to rip the Beamer apart it’s a nice unit.

Link to post
Share on other sites

Finally got what I needed for my tune and you guessed it yet another issue and can’t get it on the dyno. My cas is failing when hot ( car won’t start when hot until I dump water on cas, and starts to not fire injectors or spark i don’t know yet and runs like marbles under boost. I’ve tried 2 used ones and one brand new one from kudo which cost more than a trigger kit. My prp trigger kit I’m still waiting for new sensor to try it again with the platinum pro, cause it wouldn’t work with my platinum it kept loosing signal when running then would die. I’m starting to think that maybe I have some bad wiring somewhere because the prp trigger kit would always loose its crank signal but the cam one was fine. And now I can’t get any cas to work proper. The worst part is, is the car runs great until that cas gets hot. Maybe resistance somewhere in wiring? I dunno I’m tripping out. This ones far out.  You can here it in this video the car is barely even moving and can barely get ahead of it self when it normally has a great hard pull on 20psi. Small little imperfection on the CAs wiring but tough to say if it would cause misfires. I did have a loose bolt on the ground wire for my battery(in trunk) to frame to motor. Wasn’t crazy loose but I could move the welder gauge wire(nice and thick) back and forth until I tightened it down. Also I have my nitto can cover back on hoping it helps with some heat

2B01AE93-6565-4ADD-A1F3-4E0D9F552F2C.jpeg

97834537-097A-4EC7-A901-A07A0A643F2A.jpeg

Link to post
Share on other sites

Have you tried running a complete new loom to the CAS? may be a high resistance in it. 

What's the cost to swap to an elite ecu over there? 

  • Like 1
Link to post
Share on other sites
5 hours ago, robbo_rb180 said:

Have you tried running a complete new loom to the CAS? may be a high resistance in it. 

What's the cost to swap to an elite ecu over there? 

hey rob good to see you post up here. thats exactly what my mechanic friend said as well is that could be high resistance.  he also mentions the dwell settings maybe could be adjusted if incorrect. it is a brand new prp coilpack kit if anyone could send me there dwell settings as reference. and yes i need to switch to an elite ecu  at this point cost doesnt matter im alreay broke from the car. this platinum is killing me, but for the time being it should work mate.  that picture i posted of that small wire frayed to my cas clip, think that could cause resistance. could be 2 seperate issues the misfiring uptop and the not starting when hot. the not starting when hot is wierd cause i even had to dump water on the brand new cas to get it to start last night at the pump. i tried every one minute to crank it and it would not get fuel so i said fak it jumped out and dumped ice cold water on the cas and it fired right up no issues ran like a bat out of hell for 2 minutes then when what ever gets hot she runs like crap under boost, and everything just trips out. idles fine revs up fine but knock light wants to flash and feels like everything is way out of wack. tough hope i get it figured pulling my hair out.

Link to post
Share on other sites

everything i buy is from australia as well so cost will be the same and a bit more than what it is there(shipping etc) i waited 4 weeks for a new CAS only to find out not the issue lol. thats tuning at its finest on my end of the woods. My GTR is an alien to most people around here they stare at it like what a piece of shit lol until i crack it and scare there baby up a tree from the wastegate lol. but she runs like a shopping cart right now so illl just keep hiding in my corner till shes back to her normal self

 

Link to post
Share on other sites

Yeah with heat comes resistance. Run new wires and make sure the 2 signal wires are shielded, will fix all your problems as if you look at trigger/ignition logs you will see it going erratic as RPM increases. 

PRP dwell settings work fine for the coils. 

How fun is modifying cars 😅

I think if an Australian with some decent experience on Japanese cars came over they would fix alot of the issues people have over there. 

  • Like 1
Link to post
Share on other sites
34 minutes ago, robbo_rb180 said:

Yeah with heat comes resistance. Run new wires and make sure the 2 signal wires are shielded, will fix all your problems as if you look at trigger/ignition logs you will see it going erratic as RPM increases. 

PRP dwell settings work fine for the coils. 

How fun is modifying cars 😅

I think if an Australian with some decent experience on Japanese cars came over they would fix alot of the issues people have over there. 

Amen brother. thats why i post every hour on this site lol cause i am essentially useless lol. i do try my best tho and research and wrench very hard and put my time in mate. i can fix anything just not used to the tuning.... hammer down rb power

Link to post
Share on other sites

check out that small fray in that wire and let em know if you think that may be an issue brother. thanks mate. this issue is far out and i just wanna lean on the throttle again

 

Link to post
Share on other sites

tooted the horn to early it died on the way home today. no big deal tho figured the pump was dead, and i have 2 other pumps wired up in the tank already so i simply snipped the wire to the dead pump and wired up the other pump and away i went. man im good at breaking things lol. almost 1am when i should be home with my family the gtr almost did it this time. oh yeah oil drain almost lit on fire too haha. the old gtaaah getting spicy these days.

Link to post
Share on other sites

Happy campers with there new gear while dad wears rags to finish the car....lol

77DF5EB7-C003-402B-B3FF-B0C673C800B2.jpeg

EBA88A28-CCD2-468E-9BB9-4DA022D1F860.jpeg

8E7BE7B3-4D89-471C-AB01-2E8DD114D5E7.jpeg

Link to post
Share on other sites

Is it me or are those street drag slicks on the back of that Supra ? ! ? 

  • Like 1
Link to post
Share on other sites

Enjoyed reading this from start to finish, you certainly have a great attitude and willingness to learn about these cars. Looks like everything is well sorted at the moment mate, hopefully it stays that way.

  • Thanks 1
Link to post
Share on other sites
9 hours ago, iruvyouskyrine said:

Enjoyed reading this from start to finish, you certainly have a great attitude and willingness to learn about these cars. Looks like everything is well sorted at the moment mate, hopefully it stays that way.

Thanks good mate very kind words world needs more of that! This was me fixing the oil leak yesterday on the side of the dusty trail lol. And I mean every one minute a semi drove by And dusted me out lol. Tuning at its finest hope the e85 tune goes well today cause I worked my tail off to get the car there last night!

1A0787EC-76F2-419A-948C-0E3AB76EE18F.jpeg

Link to post
Share on other sites
11 hours ago, PLYNX said:

Is it me or are those street drag slicks on the back of that Supra ? ! ? 

you bet buddy. turbo 400 transmission, 76mm turbo 150shot, full leather interior with a cage fak the world that car started as a auto NA supra and was the benchmark and still is for the area. its left han ddrive which in our neck of the wooods is unreal because we cant passs on the hiway that well with right hand drive vehicles(no angle to see cars coming at you as we only have one divided hiway in canada. very nice car owned by a super nice guy. he actually owns toyota dealership and owns the hub dynos im using. hes let me use the toyota building if i need  a hoist for the last 15 years. great humble mate lucky to have as a friend! has a legit trd supra too ill try to snag some pics of it too. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now




×
×
  • Create New...