Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Sign in to follow this  
Sign in to follow this  
Sturdy Sleeper

My New Stagea Dramas

Recommended Posts

Hi Everyone hoping someone may be able to shed some light on a couple of things for me.

The Elec connector is under the plenum at the back of the engine and has been gnawed at by rats whilst they made it a home.

The Oil leak is a full length tapet cover gasket however it is particularly bad above the Turbo where it appears there is a bolt missing?

Can anyone shed some light for me?

Snap_008.jpg

Snap_009.jpg

Snap_002.jpg

Share this post


Link to post
Share on other sites

Looks like you have already figured it out.

What's your question?

Share this post


Link to post
Share on other sites

Is it a bolt that is missing? Or is there something else missing from here?

And does anyone know what the Electrical plug is?

Cheers

Share this post


Link to post
Share on other sites

The electrical connector is clearly attached to a knock sensor.

The oil leak photo appears to have been taken with a potato. Get a better picture.

  • Haha 1

Share this post


Link to post
Share on other sites
1 hour ago, GTSBoy said:

The electrical connector is clearly attached to a knock sensor.

The oil leak photo appears to have been taken with a potato. Get a better picture.

The knock sensor may explain some issues up high Although my money is still on Cam Angle Sensor.

And i used my inspection camera to get in there to get the photos but will try with more light tomorrow cheers

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...