Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


devoyage

2004 M35 Stagea Front Brakes Grinding

Recommended Posts

Hi all, 

Seeking advice please.  I've replaced rotors and pads with standard OEM, wheels turn smoothly and quietly at this stage.  G-clamped the pistons all the way back but as soon as I put the calipers back on I'm getting grind.  Have cleaned and lubed where required including guide pins.  Reassembled and down the road I go and still getting a consistent but not loud grind.  Could it be over torquing the guide pin bolts?  Anyone know the specs on those?   

 

Share this post


Link to post
Share on other sites

Backing plate rubbing on rotor?

Share this post


Link to post
Share on other sites

Good clearance there, appreciate the suggestion though.

Share this post


Link to post
Share on other sites

Did your new pads come with a chamfer on the leading edge? If not put one on and then as suggested bed them in (google for instructions if not sure).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...