Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

I recently  changed my radiator  after it cracked, so getting to the point i put a need radiator  in and put new coolant  in and bleeded it then drove it to the carwash and washed it after taking it for a 15minute drive the car has a jumping feeling to it when driving and when slowing down it still has a high jumpy feeling does anyone know how i can fix the problem 

Share this post


Link to post
Share on other sites

Did you wet the engine ? 

Share this post


Link to post
Share on other sites

You might have wet the air flow sensor inside the air intake.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...