Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

Good day my rb20 single cam has recently started giving me trouble to start. At cold start it will hard start till it finally do or doesnt where the rpm gauge goes all the way up to 4000rpm and red lights blinks on both the brain and the dash(under the power kickdown light) 

I had change oil, plugs, airflow, fuel pump, checked all injectors and rail regulators

Been searching the net to find solutions and haven't came up with anything. NEED URGENT HELP

Link to post
Share on other sites

Can you please restate your problem with a bit more detail. It's almost impossible to understand what it is doing from what you have posted.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...