Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


RB26DETT Tick noise


Recommended Posts

S

Hi all, so I have a problem with My RB26.

Sometimes upon startup a tick noise is intermittent or continuous. This noise slowly goes away. And yet sometimes like today, after fresh oil and filter, primed with cam trigger disconnected blah blah, started ran so quiet for roughly 10 mins, then tune changes to ghost cam idle once warm, the tick came back instantly as soon as the idle changed. 

Stock head, stock oil pump, tomei Hg,tomei head studs, oil restrictors, still twins. 90k km engine. Runs 5w50 or 10w50.

Pulled oil filter apart to inspect. Nothing clean as a whistle.

Comp is all 155 160 across the board wet. 

Can anyone shed some light? Got me stumped. 

I have videos of it Running on start-up, then once the noise came. Wish I had video running when it happened. 

Cheers 🍻 

Link to comment
Share on other sites

narrows it down a bit.....timing cover (maybe foreign object or something broken off and bouncing around) or cam covers (nasty, could be a cam oiling issue)? Cam covers are pretty easy to take off and have a look for anything amiss.

Injectors are often noisey but you should be able to isolate that (and they should not get noisey then quiet.

Link to comment
Share on other sites

Yeah injectors tick a little can here this noise over them. 

Weird it's there upon startup sometimes, last 2 times it hasn't, and today it started up fine no noises, then after a while it started then goes away eventually.

Link to comment
Share on other sites

Well, ticking lifters is usually just a (lot of work) clean, soak in oil, reassemble, or at worst, replacement, exercise. But solid lifters can only grab in he bucket bores if something has been damaged. Scuffed, squeezed, broken fragments of something else stuck somewhere, etc etc.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...