Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

Hey guys...

somereason my indicators have just stopped working.... fuse checked out ok.. and the hazard lights still work (if this is even relevant??) does anyone know which relay i am to look for? incase mine is buggered? any other likely problems?

Share this post


Link to post
Share on other sites

thats an easy relay to find as my car is stripped,, its a black square relay to the left of round one, there side by side, they are located to the way way left of the steering wheel buy lower, you may have to take tha dash facia off and take the bottom section off from undet the steering wheel.

I can get a picture if u like

Share this post


Link to post
Share on other sites

aa

Edited by Mick

Share this post


Link to post
Share on other sites

thats an easy relay to find as my car is stripped,, its a black square relay to the left of round one, there side by side, they are located to the way way left of the steering wheel buy lower, you may have to take tha dash facia off and take the bottom section off from undet the steering wheel.

I can get a picture if u like

but my guess would be they the white plug at the back top of the dash section. Then you can put new globes in while its out, and chech the indicator globes, they are standard wedge globes.

Also it may sound strange but check the fuses under the bonnet

Share this post


Link to post
Share on other sites

yeh man a photo would be good. so u say the indicator relay is to the left of the steering wheel? dont think i need to change the bulbs... hazards still work so they are fine for now....

Share this post


Link to post
Share on other sites

ill take a photo now for you, but in the in the mean time check the fuses under the bonnet

Share this post


Link to post
Share on other sites

ok.... i found a page that said the indicator fuse was the one third from bottom and in left column in fuse box near drivers right leg. this fuse was fine. im convinced its the relay... checked fuses under bonnet and there doesnt seem many there. a couple of relays but if u say its near the steering column id be more inclined to believe that.

Share this post


Link to post
Share on other sites

yes, high beam, hazard lights, ac, demister... all ok except the indicator does nothing....

Share this post


Link to post
Share on other sites

oh mate your a legend. i got under before and after your description i guessed that one. cheers dude. ill have a fiddle 2moro after work and see wat i can find out. thanx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...