Jump to content

D1_5PEC

Members
  • Content Count

    10
  • Joined

  • Last visited

  • Feedback

    0%

Community Reputation

0 Neutral

About D1_5PEC

  • Rank
    Rank: RB20E
  • Birthday 08/14/1984

Contact Methods

  • MSN
    disturbed_69_5@hotmail.com

Profile Information

  • Gender
    Male
  • Location
    Geelong

Previous Fields

  • Car(s)
    R33 Nissan Skyline gtst
  • Real Name
    Dean
  1. [yeah thanks mate just a question tho,shouldent the standerd ecu make the car run smoothly?? there awsum cars but one little thing upsets them bad its a pissoff lol
  2. its been to geelong tuneups before i bought it...looks like its goin bak lol umm the plenum wasent sealed properly in the first place thats why the power fc has a bad tune to counter airleaks and so on...this is the information that has been handed on to me as i know f*k all about jap cars.the car has new coil packs in it and does blow a lil blackish smoke on idle.
  3. well the car has one of them aftermarket plenum and it was not sealed properly so it got removed and powdercoated and then put bak on and this upset the power fc and it will not run the car anymore.so it has a stock ecu running the car now.it has new coil packs and plugs i have a bosh pump but its not yet in the car.
  4. my car is giving me nightmares!!! no one can fix the bucket of shit...it will not pull on boost it just breaks down and has a shit fit and wen u clutch it it goes into limp mode,but in the wet it arcs up fine...wont rev over 5500 rpm and i need help bad!! could this be a faulty knock sensor or somthing?
  5. the mechanic rekons he didnt touch it..i tokk it to him running and got it bak not running...its a massive headache thanx for your ideas ill check it all out and see wat happns but isnt that pin important??
  6. the cas was not touched wen i was trying to start the car...pulled a coil pack n plug out sat it on the r/cover and still nothing.the cas was in the same position as wen the car was running.i took it to get the plenum done got it bak and it wont run and that pin is snapped off in the end of the cam.now i dont know why it failed but ive been advised to replace the cam so i guess thats wat il have to do and get it tuned again...f*k:(
  7. but the motor wouldent fire as it was....wen turned by hand i got spark:S
  8. Make: NISSAN Model: SKYLINE Milage: 128,000 Transmission: 5 SPD Colour: WHITE/CARBON Location: GEELONG Complied? YES 2005 RWC supplied? NO Currently registered?NO Price: 14,000 Contact: 044 954 3635 Comments / Modifications:CARBON TOP SECRET HOOD,FIBREGLASS BOOTLID,BIG BODYKIT,GREDDY PLENUM,90MM THROTTLE BODY,FRONT MOUNT,20"DEMODA RIMS,APEXI POWER FC,2 GAUGES,2 AMPS 1 SUB(PIONEER)BRASS BUTTON CLUTCH(1,000KAYS)NEW REAR DISCS,TINTED WINDOWS,ALARM,EXHAUST,NEW SENSORS,THERMOSTAT,BOSCH 040 PUMP. Images:
  9. i have a issue with my crank angle sensor.at first we thort the cam was broken but further inspection proved wrong.its broken off in the end of the cam but the cas is fine can anyone tell me if this part is replaceable and if so shed some light on how to go about it.thanx!!!
  10. hey im the owner of the 33 that wouldent start...broken cam!!! shattered has anyone got one for sale??how much are they?? cheers!
×
×
  • Create New...