Jump to content
SAU Community

Cross Club Cruise


lordti
 Share

Recommended Posts

Hey all

me and my mates are organising another cruise for the Sunday 12th of February.

It will be a decent run into some of the nice windy roads in the countryside around canberra, but the route is yet to be decided.

Should be cars from here, ModifiedNissan.com, PreludesAustralia, Toymods, NissanSilvia.com, ACT MR2 club and anyone else who you think might be interested. The more the merrier

PM me for more details

Tim

Link to comment
Share on other sites

  • 2 weeks later...

we have a route, its roughly 170kms start to finish, and about 120 of that is really nice windy roads, just drove it and its lots of fun got really windy slow bits, some nice long straights and plenty of quick corners. one small issue is that theres 4kms of a pretty decent dirt road to get to a section but we will be taking that bit nice and slow

Link to comment
Share on other sites

cruise went off without a hitch, there were 8 cars but 1 had to pike right at the start due to an inability to see well due to hayfever

the cars that came were:

2 silvias

a 180

a cressida with a 1j in it

a gazelle

a prelude

a 911

and a station with a sr20 in it (left early)

here are some pics of the cars

P1030271.jpg

P1030273.jpg

P1030274.jpg

P1030275.jpg

P1030276.jpg

P1030277.jpg

P1030283.jpg

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



  • Similar Content

  • Latest Posts

    • I had quite the scare last night. I was on the highway just toying around with an Audi. Right after an extended WOT pull, I lost all power. I cruised to a stop on the side of the highway and realized I had no fuel pressure. I keyed on/off a few times and could hear both pumps priming but pressure was still non existent. When you need a towing on a highway in Quebec, it's an automatic call to the provincial police. They don't mess around, they'll gladly destroy your car to get it off the highway asap. I pulled my bumper off as quickly as I could as to not have it destroyed getting it onto the truck. I got lucky as the tow driver was a car guy. He entertained the police while I finished up popping my bumper off and sticking it in my window. As we started taking off, the police drove by the tow driver to tell him we couldn't leave with the bumper sticking out the window. He pulled off on the first exit he saw, did a u turn and got right back on the highway in the direction of home lol.  With no leak insight, the only thing I could think of was a torn FPR diaphragm or a popped hose inside my fuel tank. This morning on removal of my Radium twin pump hanger, one pump hose was completely shredded and the other was on the verge of the same fate. Both hoses had swelled to double their size... I have no idea how I ended up not using submersible hose but clearly that's what happened. To make things even worst, Radium supplies submersible hose with the hanger... So either they supplied the wrong hose or I had the wrong hose laying around when I assembled it.  Looking over logs, my fuel pressure dropped to 0 roughly 10 seconds after a WOT pull. I was cruising and I'm confident the motors fine. Had that happened 10 seconds earlier, I'd more then likely be pulling the motor out. New hose arrives tomorrow, I'll put it back together then. 
    • Post 2 in this thread is my C34 with a R34 manual console, you can see it is a tiny bit different but not noticeable, and clips straight in. Only issue is you have to move the g sensor a little with the manual console.
    • Welcome to SAU, they really are more fun manual
    • Any pics of that R34 console conversion?  I've been thinking this would be close, but if you have pics, that's easier than going to bother the local guy with an R34. You won't believe this, but I'm building your twin in Florida!
    • Apparently I registered here in 2007, but now I have a 98 Stagea RS Four V (series 1.5).  It came with a LOT of work done to it, and everything looks like it was done a long time ago then stored. Currently figuring out what's in it, fixing age-related issues, and 5-speed swapping I did a lot of SR/KA ROM tuning and S13/S14 building in the early 2000's, so I'm familiar with this vintage of Nissan, but this is definitely a new challenge!
×
×
  • Create New...