• Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Sign in to follow this  
10SAMM

R34 Lost Power

Recommended Posts

10SAMM    0

So for the last couple of weeks I’ve been have some issues with the electricals in my car. I first noticed that when I started my car and drove around 100m the radio would sometimes just switch off and turn back on.

However now sometimes when I drive all the warning lights will come on and then the whole car will lose power. No power steering no nothing.

I have also had an incident where I was driving and my traction control light came on and after that the steering wheel started shuddering.

 

I took the car to the mechanic who ran a scan and it came back with no error codes. At this point I am just looking for some kind of idea because I’m over only being able to drive it sometimes.

 

If anyone has experienced this or has any idea what it could be your suggestions and help would be greatly appreciated.

 

Thank you

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this