Jump to content
SAU Community

R33 Power FC problems. - Car won't start


cameron
 Share

Recommended Posts

Hi guys,

After installing a powr fc into a R33 tonight, the car won't start. Turn the ignition on and the fuses in the boot start clicking fast and the engine check light & warning lamp flash very fast.

The dislplay screen on the H/C come's up with RB25DET and nothing else but then you turn the IGN off and back on and it will come up normal and go to the menu's but when you go into a menu eg: SETTINGS > ING - it comes up blank screen as if it hasn't loaded.

What could be the problem ?

Its deffiently not the PFC as we have tryed it on another car and it works perfectly fine. - Its a brand new FC btw.

The fuel pumps making funny sounds as if its half priming but its not got the voltage to keep it priming. - more like a fuel pump miss fire :uhh:

Thanks,

Cam

Link to comment
Share on other sites

Problem Solved,

From the battery to the fues box in the engine bay had 12v but from their to FC had 7v meaning it would'nt start & fuel pump wouldnt prime. We had to re-run a power cable back to the ecu and now it works fine.

The weird thing was that it had 12v with the stock ecu and ran fine, but with the FC the same cable when down to 7v with the FC plug into the loom

The voltage sits on 14.5v when driving is this fine or too much ?

Will things go:Bang: ?

:rofl:

Jun

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



×
×
  • Create New...