Jump to content
SAU Community

rb26 into r33 gts25t


217/r33
 Share

Recommended Posts

hey guys.

I was just wondering what would be needed to do the conversion to rb26 as im looking into doing it after the new year.

- is the gear box connection the same?

- engine mounting/connection are the same as rb25?

- what will be done with the drive shafts if the rb26?

and how much would this conversion cost if i was to do it my self?

Thanks in advance :)

:)

Link to comment
Share on other sites

Doing it yourself... no more than 6k tops if you do it yourself as you say

it would be far from 10k.

Then you sell your old motor/loom you rip out

All you need is the Complete Motor with loom & ECU.

And you'll need a set of dump pipes (if you dont get em) and then just match to your existing exhaust

You could certainly get it done for less than 6k without a doubt if you sell your old motor too

Just change all the belts and stuff before you put it in.

The gearbox you have in your R33 will be fine, so driveshafts and stuff certainly dont need changing. Engine i beleive bolts up to exisiting mounts. The Joy of Nissan RB's, pretty much interchangeable

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share



  • Similar Content

  • Latest Posts

    • Trail braking done right, should have the rear unsettled, such that you're actually turning the car by a noticeable amount WITH the brakes, and hence noticeably less steering input.
    • No you don't. Just no more driving in the wet, and clean your window manually before you drive
    • I'm not sure if they tick your boxes, but Haltech would be my pick. I'm an Adaptronic guy from way back, and Haltech acquired Adaptronic to basically get Andy, AND his IP on how he does things like fuel modelling etc.
    • Just on this, as there's a huge issue in your assumption Dose.   The logic you've given, is the same logic old school NA guys give for "needing back pressure" in an exhaust. If you free up an exhaust system, and keep injecting the same fuel in etc, at the same timing, you'll typically drop power. Freeing the exhaust will often make an engine want a little bit more timing, and even sometimes a little more fuel, but then it'll make even more power.   There's many mods people do and "get no extra power" when running a comparison on the same tune. Imagine a car tuned for 91, but now we say put 98 in it, see no difference. But as we now have 98 fuel, you can run more timing, and make more power, as the 91 was knock limited.   So just be very wary in your claim of "don't retune it and do a back to back and you'll see". The correct approach would be tune the car with stock manifold, swap the manifold to aftermarket, and retune it again. But no one wants to do that, and all the results we get are "this was stock, and this is manifold changed and tuned" and people put it all down as just the tune doing it.
    • Unplug ECU. Unplug TPS. Unplug boost pressure sensor. Now, all the wires, placing your ground (black) multimeter lead at the ECU end, measure resistance of the 5V line at the boost sensor plug. Then do the same to the TPS plug. Then do the same for all the other wires that relate to the TPS, or boost sensor.   All of your measurements should be very very low. You're looking to see if wiring is out of wack here.   Secondly, from memory on the R33 (not a neo motor, so I'm assuming an r34) the ground wire for the TPS and boost sensor are NOT equal to ground of the car/battery. IE, DO NOT connect ground of the sensor to the engine/body of car. You'll get a ground loop, and/or potentially screw shit up. In electronics, ground for a circuit, is not necessarily equal to ground of another circuit.   So this leads me to ask, when measuring your 5V, how are you getting 1.5V? Where are your multimeter leads touching for both the red and black lead on the multimeter?   If you're measuring power on the sensor wire, and putting ground on the car chassis or negative battery terminal, that could be all of your issues in "getting 1.5v". Electronics engineers can do some funky stuff with circuits, and when both sensors are on, it's enough laid to alter how the ECU is functioning.
×
×
  • Create New...