Jump to content
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


Recommended Posts

Hey everyone,

I've got an R34 GTT manual turbo from an auction. The goal is to get it road registered in WA but I've ran into some issues and I need some help. I took it for a test drive today and the following happened:

  • All 4 wheels/brakes siezed after driving approx 3km  with no issues and an idle warm up.
  • Smelt burning and saw smoke coming from engine bay, passenger side, but no drastic change in temp on gauges. never happened when idle testing.
  • Idling poorly after driving

Things that I know need to be fixed on the car prior to this happening:

  • No immobilizer and a lot of loose wiring around the column (pictured)
  • Fans and AC don't blow out
  • Needs wheel allignment
  • Needs new clutch, struggles going into gears etc.
  • Needs new gearbox oil

The plan was to get the immobilizer installed tomorrow but it now has to go to a mechanic to get these new issues fixed. I would be grateful for any ideas and advice.

 

116894619_210645943700671_3614538027228673646_n[1].jpg

116719154_575727029785593_1058490021138107782_n[1].jpg

auction 1.jpg

Share this post


Link to post
Share on other sites

493878902_images(4).jpeg.e10eabd5adc131401f36e6f0a237245e.jpeg

Immobiliser is the last thing you need to do. 

Brake master cylinder sounds like it's stuffed and needs rebuild. Smell is Probably an oil leak onto the exhaust. 

Probably best to check compression and leak down and inspect turbo as it may have blown oil seal(burning oil smell) 

Car looks/sounds to be a stolen recovered. If not mechanically minded will be a long expensive problem. 

Share this post


Link to post
Share on other sites

fortunately the brakes locking issue has been resolved. The plug that controls when the brake lights are on/off wasn't adjusted properly and it was causing the brakes to lock.

The mystery of smoke coming from the engine hasn't been solved yet, but i'll update as I figure it out. could've been the clutch, brakes locking or an oil leak but right now I'm busy double checking the brake system. Will figure it out through the process of elimination considering that the clutch needs to be changed and I've just redone all the brakes.

Share this post


Link to post
Share on other sites
38 minutes ago, lxelement said:

The plug that controls when the brake lights are on/off wasn't adjusted properly and it was causing the brakes to lock.

What the f**k?

  • Like 2
  • Haha 2

Share this post


Link to post
Share on other sites
2 hours ago, lxelement said:

fortunately the brakes locking issue has been resolved. The plug that controls when the brake lights are on/off wasn't adjusted properly and it was causing the brakes to lock.

 

I hope you didn't pay someone to come to that conclusion...

Share this post


Link to post
Share on other sites
17 hours ago, Unzipped Composites said:

 

I hope you didn't pay someone to come to that conclusion...

Nah didn't pay anyone, i'm trying to resort to outsourcing jobs as a final resort. master cylinder is fine and all brakes are brand new. the plug was pushed in too far causing the brakes to constantly be pumped and on which must've been f**king with the vacuum pump for the brakes when driving by not letting them disengage. Never noticed it before because I had never driven it, but now the wheels aren't locked and can be pushed, and rolls forward/backward when riding whats left of the clutch. I'll keep posting as I clear these things out because this car has been full of really wild mods that could've only been done by crackheads, such as LED's spread through the car direct wired to the ignition barrel being constantly powered even when the cars off. I'm sure it'd make a good read.

Share this post


Link to post
Share on other sites

 The brakes on Skylines are 100% mechanical. The electrics don't affect how the brakes function. You could hardwire that switch and it wouldn't do anything but turn your brake lights on permanently. 

 

Unless you mean that the stopper was wound so far in that it prevented the brake pedal from coming all the way up? But I can't see how this would happen, then end of the switch is spring loaded and has a good 10-15mm of travel in it, while there is only maybe 5-10mm of thread behind the nut. Even if that was wound all the way in, it could maybe prevent about 1mm of travel (I think even that is unlikely though) and that is no where near enough to jam the brakes on. All it would do is cause your brake lights to not come on when you start braking.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...