Jump to content

IMG_3826.jpg

Steve85
Sign in to follow this  

Sign in to follow this  

From the album:

Steve85's LM Limited

  • 20 images
  • 0 comments
  • 0 image comments

Photo Information for IMG_3826.jpg


Recommended Comments

There are no comments to display.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Featured Images

  • Similar Content

    • By SuperSu
      Skyline ER34 GTT Turbo - TE37SL Tenis Coilovers Wide Bodykit Nismo
      http://www.gumtree.com.au/m-my-ad.html?adId=1138082139
      1998 S1 Nissan Skyline ER34 GTT 
      RB25DET 2.5L straight 6 cylinders turbo charged 

      Very good condition overall, very well looked after, a major service has been recently done at 130000kms. 
      Only GENUINE Nissan filters and fluids used. Changed engine oil, transmission oil, diff oil, coolant, brake fluids. And Oil filter, air filter, pollen filter, fuel filter. 

      Mechanically A1. Starts every time, engine runs smooth, no smoke no knock no weird noise. Ice cold air conditioning. Everything works, no issue. Interior condition is very good, clean and tidy, very few scratches and wear. 

      - New Supercharged battery $190 
      - Replaced rocker cover gaskets $200 
      - New set of NGK platinum spark plugs $130 
      - New genuine ignition coils wiring harness $160 
      - Serviced air conditioning $90 
      - Replaced all belts $140 
      - Complete set of factory floor mats 
      - New windows switches surround $100 
      - Factory Nismo body kit 
      - Reverse parking sensors 
      - Black factory weathershields 

      Upgrades: 
      - New wheels Rays Engineering TE37SL 18x9.5+22, Falken tyres $3900 
      - New Teins Superstreet coilovers, height and damper adjustable $1200 
      - GTR style wide fenders kit front and rear $1000 
      - 52mm alloy radiator and new hoses $290 
      - Front dimpled slotted brake discs $280 
      - IPR BOV blow off valve $130 
      - HID 5000K headlights $150 
      - Clear side indicators $80 
      - Series 2 boot lid spoiler $170 
      - Factory alloy pedal covers $140 
      - Pioneer MP3, AUX, USB, Bluetooth hands free head unit $170 
      - Kenwood door speakers $90 
      - Carbon fibre vinyl wrap center console $50 

      The imperfection: 
      Paint condition has seen better days. A few scratches and dents is very usual for a 19 years old car. Front wide guard and boot spoiler is in flat black, rear wide fender hasn't been put on yet but will come with the sale. Oil sump has minor leaks, but nothing serious at all, maybe a couple drops a month that's all. 

      I have been very honest with the condition of this car, I'm a car enthusiast, countless hours and dollars spent on her, I will be very sad to see her go, but due to some reasons life has to move on, I wish her can go to a good home, put on the rear wide fenders and a fresh layer of paint job, and she will be the best R34 you have ever owned. 

      $18000 ono
       
      REGO till May. RWC is not supplied! Price is quite firm, low ball offers will be ignored. Any onside inspection are welcomed, test drive only allowed when you can proved you have the adequate finance, or I will take you for a drive.
      http://www.gumtree.com.au/m-my-ad.html?adId=1138082139









       

       




       


       



    • By Jimmy1101
      Hey guys,
      Iv had my 1998 nissan skyline for about 2 months now and iv been trying to figure out why its running so rich
      Im getting 200ks A TANK!!!!. It blows black smoke and smells like fuel
      Iv changed the o2 sensor, spark plugs, maf sensor 
      When the car is off and  the engine is warm the car stuggles to turn back on... it turns on but then i have to tap the accelerator to keep it on
      When im driving and coming to a stop i clutch in and slow down and the rpms drop below 1000 and sometimes even stalls 
      When im speeding up and boost starts to build the car starts stuttering sounds like antilag tbh and i loose power
      I dont know what it can be and would appreciate any help 
      Thank you
    • By dan the man
      Ultra rare. 
      Stock R34 GTR VSpec CD player in perfect working condition. 
      $900
      Payment via PayPal 
      Worldwide shipping



    • By Nyoom
      Hey guys, first time poster, looking for some advice/help with my R33 S2 gtst.
      Pretty sure my CAS just died as the car cranks but wont start. A few weeks ago I took it out to get to my power steering pump and the key on the camshaft side was snapped and floating around.
      I managed to realign it when I put the car back together and it ran with no issues. Went down to start it yesterday and the car would not start. Cranked with enough battery voltage to start, ecu came out with code 55 so I have nothing else to suspect other than the CAS being faulty. I took the spark plugs out and they didnt smell like petrol.
      Going test with a multimeter to make sure but I had a question before I go ahead and buy a new CAS for $550 (if anyone has one id buy it for cheaper, im located in Sydney).
      I have a power fc I have yet to install, and I have not been able to find anywhere a Trigger kit that says it will work or have enough information of their page. Since ill probably have to get a new CAS my thought was why not just upgrade to trigger kit for around the same price, or just a little bit more. I'm not particularly aiming to make power that requires a trigger kit, but aligning the CAS everytime without the key is gonna get annoying. (I will eventually upgrade to tomei cams but am holding off until I finish the rest of the work I need done)
      I've had a look at most of the trigger kits out there (PRP, Ross, Hi Octance, etc.) but if anyone has any insight whether any of them will work with a Power FC that would be helpful!
    • By Justinr2911
      Hi Guys
      I have a series 1 r33gtr. The original problem was a valve guides broke and went ontop of a piston so while I had the motor out I replaced main bearings rings freshened up pistons replaced all gaskets replaced oil and water pump, I had the head rebuilt with stronger springs installed. Now I have reassembled the engine and installed it again but for some reason I have lost all boost (turbos spool up as usual) and also noticed that I have lost water from the radiator. I have checked all water lines and no mixture but when I removed the oil it was milky and found my water. It's not mixing in the water lines tho. Could anybody point me in the right direction please..
      Thanks in advance..
×
×
  • Create New...