Jump to content
SAU Community
  • Welcome to SAU Community

    Welcome to SAU Community, like most online communities you must register to view or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of SAU Community by signing in or creating an account.

    • Start new topics and reply to others
    • Subscribe to topics and forums to get email updates
    • Get your own profile page, build reputation and make new friends
    • Send personal messages to other members.
    • See fewer ads!

    Consider joining our newsletter for the latest content updates

    Click here to register


JasonMate

R33 GTS25T Compression Issue

Recommended Posts

So i brought this car a year ago with 250k on it with a blown ECU and a tight cam belt, Fixed that and is was a new car again. The problem has been that the compression cold is 140psi throughout the 6 and once hot they all drop evenly 20psi down to 120psi throughout the 6. its been like that for a year now and hasn't changed. it doesn't use oil really and doesn't fill up the catch can. the k&n filter on the catch can looks abit oily however. There's no noticeable blow by just a puff of white smoke out the catch can when you give it a hard rev.

I haven't done a leakdown test yet I've been putting it off. my question is what causes compression to drop like that? i have no information on the history besides it was owned my crackheads and it sat dormant for possibly more then 5 years. the motor looks super clean for how many km's it has and how trashed the suspension is. the car runs perfect but i can feel the 20psi loss as the car warms up.
i was thinking someone put a thicker head gasket on to drop the cr but that still doesn't answer the compression drop. its suppose to rise isn't it lol.
I've asked many mechanics and they cant explain it.
Hope someone can help!
Thanks.

Link to post
Share on other sites
Posted (edited)
3 hours ago, blind_elk said:

Have you done a wet compression test?

Its a good idea, but it will confirm worn rings. The suspension didn't get rooted because the crackies drove it to church on Sundays. Or down to Supercheap for new filters, before the car wash.

Edited by Rusty Nuts
additional information
  • Like 1
Link to post
Share on other sites

I see no problem here for an engine with 250k + the unknown jap windback kms.

Unless it's not performing right or blowing huge clouds of smoke, just turn up the boost and send it.

  • Like 1
Link to post
Share on other sites

Those comp test results seem fine considering its condition and K's. You probably already know but values can vary with different brands of comp testers. Like admS15 said, up the boost and send it.

Link to post
Share on other sites

Either ignore test results and carry on, or pull engine out and rebuild.

They are the 2 options.

Link to post
Share on other sites
Posted (edited)

hmm, its running 10psi atm, iv blown 2 turbos so far going any higher on the stock ones. Im still confused why the compression dropped 20psi just from warming up, and even more so why its 120psi hot and cold a year later. wouldnt it drop down to say 100psi once warmed up if its worn that much in the time iv owned it. if compression should be around 160-170+ and i have 120, shouldnt there be quite abit of blowby?
I forgot to take the crank case vent valve out of the manifold to get a true reading of how much blowby there is, i dc that. i took the catch can hose out and you can bearly notice air coming out, you have to squeeze the hose end and then its enough to feel like a gentle flow of air. 0 smoke. same if you give it a rev.
iv used the same comp tester for years to eliminate getting different readings.

Edited by JasonMate
Link to post
Share on other sites

I forgot to mention it was infect a females car named tarsha, idk it was badged on the back. it was all girly with pink everywhere. it also had a powercruze sticker on the back window lol idk. did people do low cr builds back like 10 years ago?

 

Link to post
Share on other sites
On 3/19/2021 at 10:05 PM, Rusty Nuts said:

Its a good idea, but it will confirm worn rings

The wet compression test confirms WORN rings. Turn boost up, wait for large clouds of white smoke, rebuild engine.

Link to post
Share on other sites

Please upload skid vids so we can confirm smoke is only from tyres and not engine 😁

  • Haha 1
Link to post
Share on other sites

All checks out. Was a little concerned at first.

 

Keep on sending it.

  • Like 2
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



  • Latest Topics

  • Latest Posts

    • I also think it would be wrong to say that RB's are weak or inherently flawed. Their oil control issues and block strength aren't a design flaw, they did exactly what they were designed to do when being used for what they were designed to do. Really it's the fact that they are quite a solid base that we are discovering their limits, because people are trying to push them to 600-700-800+ horsepower. Go and try that with a Toyota 2ZZ, the crank starts walking around at 500hp and you can't stop it. There's plenty of motors that legitimately can't handle it at all, the RBs sort of can but you're asking a lot of them.   At the end of the day, there's just no guarantees either way. You might build a 600hp engine and have it last 15 years, it might last 2 months - there's no way to guarantee it. So you're playing an odds game, you're rolling the dice. And if you aren't comfortable rolling the dice with the amount of money that it costs to play the game, then the best advice anyone can give is to not do it. Don't go to the casino and put all your money on Red if it will hurt too much when you land on Black.   Just ask Laine@bcozican, he's the sort of man that stands with his back to the table and barely even checks what colour the last throw landed on before rolling again 🤣🤣🤣❤
    • Nismo R35 GT3 Brembo Racing Caliper 2 sets front calipers, new and unused Suit high performance modification to any GTR Skyline with limited modifications for adaptors etc. Perfect application for 'Time Attack' build Item location is UK, worldwide shipping available and as part of purchase cost. Price for 1 x pair ( LHF + RHF ) GPB£3250 - AUS$5850 Happy to discuss further with technical support, information and pictures +447552494484
    • Ahh I see, I thought you were saying you were going back to a 2.6L. Just misunderstood what you meant by based.    Carry on then!
    • But the simple way is just go to the R33 GTS page at GTRRegistry and all the details same as FAST are there.
    • This is the factory procedure; 13.Crank Pulley A: REMOVAL 1) Remove the V-belts. <Ref. to ME(H4SO)-36, REMOVAL, V-belt.> 2) Remove the crank pulley bolt. To lock the crankshaft, use Shop Tool 499977100 CRANK PULLEY WRENCH 3) Remove the crank pulley.   B: INSTALLATION 1) Install the crank pulley. 2) Install the pulley bolt. To lock the crankshaft, use Shop Tool 499977100 CRANK PULLEY WRENCH (1) Clean the crankshaft thread using compressed air. (2) Apply engine oil to the crank pulley bolt seat and thread. (3) Tighten the bolts temporarily with tightening torque of 44 N·m  or   33 ft-lb). (4) Tighten the crank pulley bolts. Tightening torque: 180 N·m   or  132.8 ft-lb)   3) Check that the tightening angle of the clamp pulley bolt is a minimum of 65°,  Perform the following procedures when less than 65°. (1) Replace the crank pulley bolts and clean them. Crank pulley bolt: 12369AA011 (2) Clean the crankshaft thread using compressed air. (3) Apply engine oil to the crank pulley bolt seat and thread. (4) Tighten the bolts temporarily with a tightening torque of 44 N·m (4.5 kgf-m, 33 ft-lb). (5) Tighten the crank pulley bolt an additional 65° to 75°.  
×
×
  • Create New...